Hi all:

      Recently i do a test of postgresql. To get more information of the functions in PostgreSQL, i use
 
opgprof and opannotate, which are two tools in Oprofile. But i can't work with the tools correctly.

PostgreSQL is compiled with -g option and the errors are like this:

 opgprof error: parse_filename() invalid filename: /var/lib/oprofile/samples/
current/{root}/var/lib/oprofile/samples/current/{root}/home/ubuntu/tpcc-uva/bin/tm/{dep}/{anon:[vdso]}/7208.0x7fff7a972000.0x7fff7a974000/CPU_CLK_UNHALTED.90000.0.all.all.all/{dep}/{root}/var/lib/oprofile/samples/current/{root}/home/ubuntu/tpcc-uva/bin/tm/{dep}/{anon:[vdso]}/7208.0x7fff7a972000.0x7fff7a974000/CPU_CLK_UNHALTED.90000.0.all.all.all/{cg}/{root}/usr/bin/oprofiled/CPU_CLK_UNHALTED.90000.0.all.all.all

and opannotate

warning: [heap] (tgid:7302 range:0x8e7000-0xa18000) could not be found.
warning: [vdso] (tgid:7295 range:0x7fff3ddfe000-0x7fff3de00000) could not be found.
warning: [vdso] (tgid:7296 range:0x7fff3ddfe000-0x7fff3de00000) could not be found.
warning: [vdso] (tgid:7297 range:0x7fff3ddfe000-0x7fff3de00000) could not be found.
warning: [vdso] (tgid:7298 range:0x7fff3ddfe000-0x7fff3de00000) could not be found.
warning: [vdso] (tgid:7299 range:0x7fff3ddfe000-0x7fff3de00000) could not be found.
warning: [vdso] (tgid:7300 range:0x7fff3ddfe000-0x7fff3de00000) could not be found.
warning: [vdso] (tgid:7301 range:0x7fff3ddfe000-0x7fff3de00000) could not be found.
warning: [vdso] (tgid:7302 range:0x7fff3ddfe000-0x7fff3de00000) could not be found.
opannotate (warning): unable to open for reading: aset.c
opannotate (warning): unable to open for reading: heaptuple.c
opannotate (warning): unable to open for reading: bufmgr.c
opannotate (warning): unable to open for reading: execQual.c
opannotate (warning): unable to open for reading: list.c
opannotate (warning): unable to open for reading: nbtree.c
opannotate (warning): unable to open for reading: fmgr.c
opannotate (warning): unable to open for reading: catcache.c
opannotate (warning): unable to open for reading: nodeIndexscan.c
opannotate (warning): unable to open for reading: clauses.c
opannotate (warning): unable to open for reading: ri_triggers.c
opannotate (warning): unable to open for reading: lock.c
opannotate (warning): unable to open for reading: planner.c
opannotate (warning): unable to open for reading: selfuncs.c
opannotate (warning): unable to open for reading: postgres.c
opannotate (warning): unable to open for reading: trigger.c
...


if i want to use the two tools on PostgreSQL , what should i do? (change the option of PostgreSQL or something else?)


                                                    Best wishes

                                                      Yyan