Hi all,

My main goal is to run oprofile on an ARM device. More specifically on a Google Android Developer phone 1.

So as a first step I tried to get it to build for my Linux workstation. I installed the prerequisites explained in http://oprofile.sourceforge.net/doc/requirements.html and ran "./configure --with-kernel-support" and this worked.

However, "make" didn't and I got the following error:

In function ‘int open(const char*, int, ...)’,
    inlined from ‘bool copy_file(const std::string&, const std::string&)’ at file_manip.cpp:47:
/usr/include/bits/fcntl2.h:51: error: call to ‘__open_missing_mode’ declared with attribute error: open with O_CREAT in second argument needs 3 arguments
make[3]: *** [file_manip.o] Error 1
make[3]: Leaving directory `/opt/oprofile-0.9.4/libutil++'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/opt/oprofile-0.9.4/libutil++'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/oprofile-0.9.4'
make: *** [all] Error 2

Feels like a version mismatch..but I don't know.

Any help is greatly appreciated!