Hello Robert,

The answers are inline.

 # uname -a
Linux domU-12-31-39-07-7A-71 #1 SMP Fri Feb 15 12:34:28 EST 2008 x86_64 GNU/Linux

 # zgrep -i oprofile /proc/config.gz
gzip: /proc/config.gz: No such file or directory

 # dmesg | grep -i oprofile
xenoprofile_init: ret 0, events 2, xenoprof_is_primary 0
# find /dev/oprofile/

# echo $(cat /dev/oprofile/cpu_type)

Thanks and Regards,
Nupur Garg

On Fri, Oct 16, 2009 at 4:17 AM, Robert Richter <robert.richter@amd.com> wrote:
On 15.10.09 23:21:36, nupur garg wrote:
> Hello,
> The oprofile device is mounted.


what gives the following on your system with oprofile mounted?

 # uname -a
 # zgrep -i oprofile /proc/config.gz
 # dmesg | grep -i oprofile
 # find /dev/oprofile/
 # echo $(cat /dev/oprofile/cpu_type)

> I had one xen image also, I tried on it and oprofile worked perfectly fine
> on it. The difference between the ec2 image and this image I found was that
> in /sys/devices/system/ directory oprofile directory was not there. Looking
> around more I found that while compiling the kernel, Oprofile has to be set.

This happens if CONFIG_PM is not set and is only needed for


Advanced Micro Devices, Inc.
Operating System Research Center
email: robert.richter@amd.com