Dear All,
I did the following:
1. Installed and run oprofile in my PowerPC embedded system.
2. Used oparchive to archive the results - opr_run1
3. Optimized code and executed it under oprofile again.
4. Archived the results as in #2 - opr_run2
5. When I run opreport -l { archive:./opr_run1 } { archive:./opr_run2 } I get to see the differential profiling
(as expected).
All the steps above were on the embedded PowerPC e300 system. The version of oprofile used in 0.9.2 and
I can't change it.

However when I export the archive to my Linux machine running on i386 and oprofile version 0.9.4,
and then running #5 there, I get the error message: oprofile: could not open unit mask description file
/usr/local/share/oprofile//invalid cpu type/unit_masks
So, I installed oprofile version 0.9.2 on my Linux machine and tried #5 again. But this gave another error message:
../var/lib/...bin/bash/CPU_CLK.100000.0.all.all.all : Invalid argument. (I have omitted some path names here)
Can someone help me please?
I need to run the analyses offline since I dont get access to the embedded machine and the disk space
available there is rather small.
I appreciate you help.