Hi Folks,

I had installed OProfile 0.9.3 version ( latest ) on my workstation.

The Processor is an ARM/Xscale3 processor.

I am running Linux version

I browsed through the code of OProfile Kernel driver and found that there is support for XScale3.

But with the user space tools I found that there is no support for XScale3.

I browsed through that code as well and figured out that there are few structures which needs to be updated with XScale3 information other wise it throws an error
saying "cpu_type unset is not valid, Force OProfile in timer mode" I updated the structures with XScale3 information and when opcontrol --start is run this error is not shown.
(With out these updates when tried to run opcontrol --start, cpu_type error was coming)

After the above changes I am able to profile the kernel and applications as well.

But after profiling if I run the command "opreport -l"
It shows the following two lines followed by the data in the format given below. The output shows the speed as 0 MHz. What does this mean?
and it also shows that profiling through timer interrupt ( Deos this mean that the processor though has support performance counters doesn't have enough hardware support to generate the interrupt ).
Please Clarify...

CPU: CPU with timer interrupt, speed 0 MHz (estimated)
Profiling through timer interrupt

samples  %        app name                 symbol name

How will I make sure that the OProfile is profiling precisely?


Want an e-mail address like mine?
Get a free e-mail account today at www.mail.com!