unable to load oracle client libraries

  • develop1

    develop1 - 2013-07-12

    I have opr installed.
    uname -a
    Linux xxxxxxxxx 3.0.58-0.6.6-default #1 SMP Tue Feb 19 11:07:00 UTC 2013 (1576ecd) x86_64 x86_64 x86_64 GNU/Linux

    When I try to add a record to the OPR repository I get:

    opr -a -f mdbs musr me
    unable to load oracle client libraries.
    tried: /u01/app/oracle/product/, /u01/app/oracle/product/

    what seems odd is I can do an ls -l on the above files mentioned.
    I find they ARE present with permissions wide open.

    At this point I'm at a loss as to what to do next.

    ls -l /u01/app/oracle/product/
    lrwxrwxrwx 1 root root 17 Jul 11 20:20 /u01/app/oracle/product/ -> libclntsh.so.11.1

    cd /u01/app/oracle/product/
    ls -l
    lrwxrwxrwx 1 root root 17 Jul 11 20:20 libclntsh.so -> libclntsh.so.11.1
    -rwxrwxrwx 1 oracle dba 52868218 Jul 11 20:14 libclntsh.so.11.1

    Last edit: develop1 2013-07-12
  • develop1

    develop1 - 2013-07-12

    the issue turned out to be a problem with the first entry in the /var/opt/oracle/crontab file.

    It so happens in our case this record had an extra whitespace character preceeding the foldername. the typo looked this (where /a/b/c/d was an acutal oracle_home).

    *: /a/b/c/d:N

    the space preceeding the /a was being treated by OPR as part of the folder name string.
    Of course no such leading whitespace folder exists so the error message of not being able to find the library was correct.

    The OPR error message does display the location(s) it tried to find the library.
    In this example the leading whitespace was present in that error message but almost impossible to see when reading said message.

    OPR is now working as desgined.

    Thank you.


Log in to post a comment.