Strange problem with PHOTO and IMAGE @stereotype

  • nikos lianeris

    nikos lianeris - 2013-08-18

    I have an entity object that has one of its properties marked with @Stereotype("PHOTO") and although it loads correctly when i visit localhost:8080/myApp/modules/TheModule and I can see the links for changing and deleteting image,the problem begins when I choose the image for uploading and press load image button.From that moment the application enters an "endless loop" actually of sending request to the server,the server reponses,the request is interrupted and the application resends the request.
    The photo property is declared:
    private byte[] photo;
    I've also tried to use @Lob annotation with no results.
    I've also tried demo and I've noticed that change image functionallity is working correctly there.
    Is there something I have to configure or do in order to avoid the above mentioned problem
    Thank you in advance for your time

  • Javier Paniza

    Javier Paniza - 2013-08-20

    Hi Nikos,

    I have never seen that behavior. Maybe, it's something related with your configuration or something special you have in your code. Anyways, I would like to reproduce it.

    Could put here a complete but simple example of code that I can copy and paste in my environment to reproduce your error?

    Help others in this forum as I help you.
    Need more help? Get OpenXava professional support.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks