error openwebspider

Help
2008-04-01
2013-07-16
  • lenghuchong

    lenghuchong - 2008-04-01

    hi i have error message "Segmentation fault (core dumped)" i don't know meaning please help me to solve error

     
    • lenghuchong

      lenghuchong - 2008-04-01

      i install openwebspider version 0.6.1 on ubuntu 7.0 mysql 5 php5

       
    • Darren

      Darren - 2008-04-26

      Hi all,

      Me too getting the same error running openwebspider on centos 5 with 2GB ram with 1ghz  cpus x2 using command -i hostname -u -l 2000 -t 6 this command the crawler runs anything form 20min to 4 hours before segment fault accurs i have the cralwler running on four servers all with same problem all running linux centos 5. Last night i tried running this command -i hostname -u -t 6 on one of the servers at present it is still running after 8 hours the only problem with this is that the spider is getting trapped into very large sites any thoughts for a soultion would be could.

      all the best

      Darren

       
      • Serge

        Serge - 2013-07-16

        Hi Darren and everybody !

        I have CentOS 6.4 - may be you could help me with a hint to install modules under
        /var/www/vhosts/openwebspider/07/modules/regexFilter/regexFilter.c
        When I do as instructed (I means commands inside regexFilter.c to compile)

        gcc -g -c regexFilter.c
        that's ok, but next command

        gcc -g -shared -W1,-soname,regexFilter.so.0 -o regexFilter.so regexFilter.o -lc
        gives the following report

        /usr/bin/ld: regexFilter.o: relocation R_X86_64_32 against `.rodata' can not be used when making a shared object; recompile with -fPIC
        regexFilter.o: could not read symbols: Bad value
        collect2: ld returned 1 exit status

        May be you or forum knows an answer.

        Thanks in advance !
        Have a nice day !
        Serge

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks