"no response" from OpenVPN control

Help
cortlieb
2008-01-02
2013-04-08
  • cortlieb

    cortlieb - 2008-01-02

    Hi all,

    whenever I start OpenVPN control with (what I think is) a valid configuration, it stops responding to Windows (XP), i.e  the programs hangs. The hourglass is displayed and there is no reaction from the program at all.
    I tried it with version 1.01 and 1.02, both is the same.

    When I put in a wrong IP-Adress or port, I get the message "Could not establish connection with OpenVPN-Control via 7505".

    With correct values there is an entry in the OpenVPN server-log, that there was a connection for management (MANAGEMENT : Client connected from <IP-adress>).

    I use OpenVPN-Control on the server without SSH-connection. I tried IP 127.0.0.1 and the local IP-Adress, both reacts as decscribed above.

    Are there any hints what to do ?

    Thanks

    Christian

     
    • Ron Dorn

      Ron Dorn - 2008-01-02

      Unfortunately the management port of OpenVPN only supports one connection to the management port at a time. If more then one connection exists, the port accepts the connection, and then returns no data, and hangs my application.

      I found solutions to this under linux, but not one for Windows, so no solution has been implemented.

      Please be sure that no other processes or machines are attempting to use the management port.

       
      • cortlieb

        cortlieb - 2008-01-02

        Hi Ron,

        thanks for your _very_ fast answer!
        Unfortunately I saw just after my entry, that there is already a very similar thread.
        But it seems, that there is no solution up to now.

        I'm running OpenVPN-Control on the same machine as the OpenVPN server.
        I'm able to connect by telnet (locally and from an other machine), but not with OpenVPN-Control.

        I'm sure that there is no other management connection to this server.

        As soon as I stop the OpenVPN server OpenVPN-Control comes back to live again with the message "Could not establish ...".

        Do you have any other hints for me ?

        Thanks

        Christian

         
        • Ron Dorn

          Ron Dorn - 2008-01-02

          The only time I have seen that symptom, is when the telnet port is in use.

          What version of OpenVPN are you running.

           
    • cortlieb

      cortlieb - 2008-01-03

      I'm running OpenVPN version 2.0.9

      I´did the following :
      - start 1st telenet-session : OK
      - start 2nd telnet-seesion : no connection
      - stop 1st telnet-connection : 2nd telnet-connection comes alive
      - stop 2nd telnet-connection
      - start OpenVPN-Control : program hangs
      - start 3rd telenet-conection : no connection
      - cancel OpenVPN-Control : 3rd telnet-connection comes alive

      So I agree with you, that OpenVPN-Control acts as if there is already a connection to the OpenVPN-server, but there is none !

      Hmm, strange, since it seems to run for some (most ?) people.

      Christian

       
    • habmeister

      habmeister - 2008-02-12

      Well I have the exact same problem!

      I am using windows 2003, openVPN 2.0.9 and OpenVPN-Control v 1.02e.

      I start openVPN with the config file (as a service or directly) but as soon as I try to make a connection with OpenVPN-Control, the program hangs. When I stop openVPN then OpenVPN-Control program starts responding again and gives the message "Could not establish...".

      I can telnet management with no problem, so I don't think that any other application is using the port.

      Can you think of anything else that might cause this problem?

       
      • Ron Dorn

        Ron Dorn - 2008-02-12

        OpenVPN by default only allows telnet from 127.0.0.1, can you telnet to that address??

        Also OpenVPN only allows one connection at a time. If there is any other connection to the management port, OpenVPN will open the network connection, but refuse to communicate further until the other connection is dropped.

         
    • habmeister

      habmeister - 2008-02-13

      Well, reading a similar post in the forum, I managed to connect but only from another machine in the network.

      From the server I still cannot connect, the program always freezes.

      Doing the proper changes in the config file (I changed the address to connect from another machine) I can telnet 127.0.0.1 and of-course localhost at the configured port.

      Since I can telnet I am assuming that there is no other process using the port. Moreover, I cannot find any process using the port.

       

Log in to post a comment.