OpenVPN-Control 1.02 on Windows Server 2003

  • robmeyer

    robmeyer - 2006-06-16


    I installed OpenVPN 2.0.7 on Windows Server 2003 SP1 which works fine so far and then i tried to use OpenVPN-Control 1.02 on this server after i activeted the management port in the openvpn-server-config file.
    But now the application hangs after i started it, when i click into the window the menu-entries hide and there is a white background where the menu was and the hourglas is displayed permanently.

    Is there something i should install additional to OpenVPN-Control like perl or something else to use it on Windows Server 2003?

    Best regards for your efforts and your advice,

    • NeverQuit

      NeverQuit - 2006-07-17

      I also have the same issue with this same configuration.

      I hope someone out there can shed some light on our problem as I don't think that we would be the only two people with the same issue.

      You help would be extremely appreciated,

      • Ron Dorn

        Ron Dorn - 2006-07-17

        My initial reaction is this is likly to be the built in windows or other firewall blocking the network connection.

    • NeverQuit

      NeverQuit - 2006-07-18

      Unfortunately this is not the case.

      The server is on the private side of a Cisco PIX Firewall.

      Currently I'm not running any firewalls on the server.


      • Ron Dorn

        Ron Dorn - 2006-07-18

        Can you telnet to the managment port from a command shell. If you can not do it via the command shell, the software will not be able to connect to the managment port either.

    • NeverQuit

      NeverQuit - 2006-07-19

      I receive this response when I telnet into the management port...

      >INFO:OpenVPN Management Interface Version 1 -- type 'help' for more info

      Your help is really appreciated,

    • Ron Dorn

      Ron Dorn - 2006-07-22

      Can you send me the content of your openvpn_control.conf file.

    • NeverQuit

      NeverQuit - 2006-08-03

      I apologize for taking so long to respond, I had to finish up on a couple of other pressing IT projects.

      OpenVPN.ovpn management setting...
            management 7505


      Additional Notes...
           When I purposely set the wrong IP in OpenVPN Control the program seems to work.
           It will come up with error message "Could not establish connection with OpenVPN-Control via 7505"
           When I use the correct IP the program freezes.
           I tried "OpenVPN management/OpenVPN Control" settings with loopback IP, Bridged TAP devise IP and secondary NIC IP with the same results.

      Once again your help is really appreciated...

    • Ron Dorn

      Ron Dorn - 2006-08-04

      Ok, so it looks like your trying to run openVPN control from the same machine that serves as the OpenVPN Server??

      Something to try is, while theory, should work fine. Try changing the ip address to whatever the internal ip address of the machine is?? see if that makes a difference.

      If it does not, can I see your config file for the open vpn server??

    • NeverQuit

      NeverQuit - 2006-08-04

      Yes... I am running OpenVPN Control on the same box as OpenVPN.
      I tried your suggestion but unfortunately it did not work.
      Here is my OpenVPN server configuration.

      # Listening on local TAP device
      local xxx.18.112.27

      # I tried this setting
      # management xxx.18.112.27 7505
      # I also tried a secondary NIC IP
      # management xxx.18.112.19 7505
      management 7505

      port 1194
      proto udp
      dev tap
      dev-node tap-bridge
      ca ca.crt
      cert Server.crt
      key Server.key
      dh dh2048.pem
      auth-user-pass-verify chkpwd.cmd via-env
      ifconfig-pool-persist ipp.txt

      server-bridge xxx.18.112.27 xxx.18.112.200 xxx.18.112.247

      push "route xxx.18.112.0"
      push "route xxx.18.113.0"
      push "route xxx.18.114.0"
      push "route xxx.18.115.0"
      push "route xxx.18.150.0"
      push "route xxx.237.194.0"
      push "route xxx.69.1.0"
      push "route xxx.69.9.0"

      # Routing client web browsing and and DNS lookups through the VPN
      push "redirect-gateway xxx.18.112.249"
      # Pushing our DNS to clients
      push "dhcp-option DNS xxx.18.112.14"

      keepalive 10 120
      tls-auth ta.key 0
      cipher BF-CBC
      max-clients 100
      status openvpn-status.log
      verb 4

    • Ron Dorn

      Ron Dorn - 2006-08-04

      Everything seem to be looking good, and there is nothing that jumps out at me as problamatic.

      I don't have 2003 Server to test with, but that 'could' be an issue??

      Can you try loading ActiveStatePerl and run the program from source. (There is a src directory included with every distribution). Maybe it will give an error message, or some other clue. I might also be able to provide you with a verion that dumps debug code to try and locate the issue.

    • NeverQuit

      NeverQuit - 2006-08-09

      I ran from the command line and had the same results "OpenVPN-Control Not Responding".
      There were no error messages at the command prompt.

      Addtional Info...

      OpenVPN-Control is connecting to the Server, here is the line from the Server-status.log
            Wed Aug 09 14:27:51 2006 us=148662 MANAGEMENT: Client connected from

      When I force the program to close this line is entered into the status log.
            Wed Aug 09 14:29:32 2006 us=595746 MANAGEMENT: Client disconnected

      • Ron Dorn

        Ron Dorn - 2006-08-09

        Can you telnet to the managment port and run a command, and then copy and past all the input/output in an email. I want see if your OpenVPN server is sending the  string I am excepting after connection.

    • sniffix

      sniffix - 2006-10-30


      The same problem appears when running OpenVPN control on Windows XP SP2. Sometimes there is a connection and you can see an active client session, but even in this case after the next refresh period it hangs. I tried it on 2 different machienes with the same result. In the logging of the server you can see a line : "...MANAGEMENT: Client connected from", but mostly it's hanging or hangs after refresh.

      kind regards, 

      • Ron Dorn

        Ron Dorn - 2006-10-30

        This symptom is most often caused by multiple connections to OpenVPN server. The OpenVPN server only supports a single connection, and when a second connection is attempted, the connection is opened, but hangs until the first connection is terminated.

        I attempted to fix this, but the easiest and most strait forward fix worked great on Linux, but did not work under Windows.

        Please be sure that no other process is talking with the OpenVPN management port.

    • sniffix

      sniffix - 2006-11-02

      Yes the hanging appears when you have a second openvpn-control in the task manager. But as soon as the review timer expires, or when you manually ask for a refresh then you see a "Not Responding" in the Task Manager, and the next click action in the OPENVPN application seems to restart it and then you see a SECOND OpenVPN Control application, making the next attempt fail of course from the beginning...

      Further building on your information, I found out that the problem only appears as soon as there is a client connected to the server, and in my case I was experimenting with client and server on the same machiene, with 2 different TAP devices. While running the OPENVPN GUI, all seems to be ok and the connection client-server seems to work, but not with OPENVPN CONROL. So I figured that maybe the client and server OPENVPN applications were both using port 7505 for the managing port (although only the server had the statement in his config, the client per default maybe...). I  forced the CLIENT's managing port to be 7507, in order to avoid conflicts, and indeed now the OPENVPN control is not hanging any more, but... I see also no clients connecting anymore, except if I start the client application first, and then the server, but later tha binding seems to change again and the applcation stops responding. So the problem seems to be that the OPENVPN CONTROL does no bind to the right OPENVPN process (the one of the server). I will try this on 2 different machienes from now on and let you know the result. I posted this response for those who try to do the same trick as I did (client and server on the same machiene).

      Thanks for your hint.

    • Robin Tan

      Robin Tan - 2006-11-05

      I must say I have the same problem with OpenVPN 2.09. It starts fine but hangs if I try to refresh. All I did was to add to config file

      management localhost 7505

    • sniffix

      sniffix - 2006-11-06


      Different machienes for client and server did not give a solution, I even tried to run OPENVPN CONTROL on a third machiene, in order to avoid any conflict. The OPENVPN CONTROL application hangs shortly after being connected to the server, after it sends a "status 1" command and gets a response from the server. I guess there is something it does not like in the response, so maybe there was a change in the status format in OPENVPN 2.09 compared to the version that OPENVPN CONTROL was tested with originally? If I knew what the version was ,I could try this...

    • light_man

      light_man - 2007-02-22


      is this problem already resolved, i've got the same issues with openvpn control and win2k3, i really like to use this program, somebody got any idea?

    • open_letter

      open_letter - 2007-03-08

      OK... using the Server-Bridge or Internal IP address worked for me.

      "management 7505"
      Only allowed localhost connections, and hangs (at lease on my machine)

      "management 7505"
      Where '' is my Server-Bridge IP address, allows OpenVPN-control to work both locally and remotely when this IP is used in the Configure OpenVPN-Control settings.

      The server would only respond from the IP address set in the OpenVPN server configuration, so the management service ignores requests from the other IP addresses.

    • Mikko

      Mikko - 2007-10-13


      I'm still having this issue..  if someone has a working solution, I would be very very happy to know about it!

      I've tried:

      "management localhost 7505", hangs
      "management 7505", hangs (my servers ip address is that)
      "management 7505", hangs (the "vpn server address" of my server)

      So none of those works.

      I don't have a bridged vpn, I use routing.


Log in to post a comment.