Help save net neutrality! Learn more.
Close

Adito 0.9.1 Install Help

Help
Bigfoot
2009-01-08
2013-05-28
  • Bigfoot

    Bigfoot - 2009-01-08

    Hello all,

    I am very thankful for Adito.  I am a former SSLExplorer user and was greatly disappointed when they stopped support of the software.

    Now, for my dilema.  I am running a home file server using Ubuntu 8.04.1, 64-bit.  I have successfully installed Adito 0.9.0 and it works fine using Java 1.5.

    I have tired to install Adito 0.9.1 and Java 1.6, but it will not run.  The install works fine, but when I try to run the Adito server, I get an error about not finding the wrapper in x86.  I thought it would look for it in x64 since I am running a 64-bit system.

    I have set the JAVA_HOME to the Java 6, but I still receive the error.  I an experience linux user, but this one has me baffled.   I already unistalled 0.9.1, but can try it again to provide more specific info. 

    I use the this at work quite often and would like to get the newer version working.  Anyone have any ideas as to what might be the problem?

    Thanks in advance for any assistance.

     
    • Bigfoot

      Bigfoot - 2009-01-10

      Here's the error message I receive with 0.9.1:

      ant start
      Buildfile: build.xml

      start:

      create-wrapper-conf:
           [copy] Copying 1 file to /opt/adito-0.9.1/adito/conf
           [echo] Creating wrapper configuration dynamically
           [echo]
           [echo]    Java executable: /usr/lib/jvm/java-6-sun-1.6.0.07/jre/bin/java
           [echo]    Wrapper directory: install/platforms/linux/x86

      set-tools:

      check-tools:

      check-permissions:

      start:
           [exec] Starting Adito...
           [exec] exec: 370: install/platforms/linux/x86/wrapper: not found
           [exec] Result: 2
           [echo] Adito started

      BUILD SUCCESSFUL
      Total time: 1 second

       
      • DSi3G

        DSi3G - 2009-05-18

        Hi,

        I have the same problem.
        [exec] exec: 370: install/platforms/linux/x86/wrapper: not found

        Did you solve it ?

        Thanks.

         
    • Nicholas Basham

      Nicholas Basham - 2009-01-12

      Have you tried getting 0.9.1 working using the JDK 1.5 environment?

      Also, look in your /etc/init.d/adito service start up file and look at the "export WRAPPER_CONF" line.  Open the file referenced (place/you/installed/adito/conf/wrapper.conf) and look at line six (wrapper.java.command).  What does this say - does it point to your 1.6 or 1.5 environment?

      I might be wrong, but I don't think that Adito cares what the JAVA_HOME environment variable is after it has been configured.  I think that it uses the line in the wrapper.conf to point to the JDK to be used.

      Nicholas

       
      • Bigfoot

        Bigfoot - 2009-01-13

        Thanks for the reply.  I did try it with 1.5, but no luck.  The install tutorial says to use Java 6 for 0.9.1.  The wrapper line you referred to is set dynamically, so it cannot be set manually.

        It does make a difference what JAVA_HOME is set to as when you run ant start, it tells you which java is being used.  I was hoping to get is resolved, but I haven't received much help as of yet.

         
    • Bigfoot

      Bigfoot - 2009-01-14

      Well, I finally managed to get 0.9.1 working :)  I am using Java 1.5 and as long as I don't change any server settings under system configuration, it works fine.  If I try to change something that requires a restart of the Adito server, it stops working. 

      I read in another thread where someone else had the same issue.  So, I won't mess with any of those settings.  The only one I was trying to enable "allow open web folders in FireFox" and that killed it.

      I look forward to more extensions and progress to a more stable solution.  Thanks to all the developers who put a lot of hard work into this software.

       
    • mattock

      mattock - 2009-01-14

      I thought I had all of the wrapper problems nailed down, but it seems some are still left.

      We're currently migrating from Ant build system to Maven2. I'm hoping to convert Adito to a 100% standard web application and provide many other benefits. This would allow us to get rid of the wrapper for good. As I'm not a coder myself, I don't know if that's doable or not. We'll see.

       
    • Bigfoot

      Bigfoot - 2009-01-14

      Not a problem for me, just wanted to let everyone know I am up and running again with the newest version.  I work for DOD, so I have many strict security polices to work around with VPN.  This solution has worked the best for me as no additional software is required on the client end.

      I look forward to the progress of this software.  Hopefully the coders will be successful with the migration and achieve your goal.  I would be glad to lend a hand with testing, but I am not an experience coder myself.

      Thanks again for providing us with a viable and no cost solution!

       
    • Jeff Chen

      Jeff Chen - 2009-05-21

      Hi, This is because the adito use I386 version rather than 64bit version.
      One solution is backup install/platforms/linux/x86 to install/platforms/linux/x86.bak
      then mkdir install/platforms/linux/x86 and copy install/platforms/linux/x86-64/* to the new x86 folder.
      Try it.

       
  • Noel Kelly

    Noel Kelly - 2009-11-16

    I get the same error - did anyone ever solve this?

     
  • Noel Kelly

    Noel Kelly - 2009-11-16

    I have tried creating a new x86 directory with the x86_64 files inside but now get this error:

        root@64:/opt/adito-0.9.1# ant start Buildfile: build.xml
       
        create-wrapper-conf:
              Copying 1 file to /opt/adito-0.9.1/conf
              Creating wrapper configuration dynamically
             
                 Java executable: /usr/lib/jvm/java-6-sun-1.6.0.16/jre/bin/java
                 Wrapper directory: install/platforms/linux/x86
       
        set-tools:
       
        check-tools:
       
        check-permissions:
       
        start:
              Starting Adito…
              FATAL  | wrapper  | Unable to resolve the full path of the configuration file, conf/wrapper.conf: No such file or directory
              Result: 1
              Adito started
       
        BUILD SUCCESSFUL Total time: 0 seconds

     
  • Noel Kelly

    Noel Kelly - 2009-11-16

    After playing with the build.xml script I gave up on 64bit and moved to a 32bit platform which worked perfectly.

    Something not quite right with the 64bit wrapper stuff…

     
  • Noel Kelly

    Noel Kelly - 2009-11-16

    After playing with the build.xml script I gave up on 64bit and moved to a 32bit platform which worked perfectly.

    Something not quite right with the 64bit wrapper stuff…

     

Log in to post a comment.