Errors Installing

Support
Morons
2006-07-31
2013-04-17
  • Morons
    Morons
    2006-07-31

    [root@echo ~]# rpm -i openvpn-admin-1.9.3-1.noarch.rpm
    error: Failed dependencies:
            gtk-sharp2 >= 2.3.91 is needed by openvpn-admin-1.9.3-1.noarch
            mono(Mono.Posix) = 1.0.5000.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono(System) = 1.0.5000.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono(gdk-sharp) = 2.8.0.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono(glade-sharp) = 2.8.0.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono(glib-sharp) = 2.8.0.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono(gtk-sharp) = 2.8.0.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono(mscorlib) = 1.0.5000.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono-core is needed by openvpn-admin-1.9.3-1.noarch

    Then I did
    [root@echo ~]# urpmi --noclean gtk-sharp2

          8/9: glib-sharp2           #############################################
          9/9: gtk-sharp2            #############################################
    /var/tmp/rpm-tmp.77760: line 1: /usr/bin/monodoc: No such file or directory
    error: %post(gtk-sharp2-2.3.91-3mdk.i586) scriptlet failed, exit status 127

    Then I Tried again
    [root@echo ~]# rpm -i openvpn-admin-1.9.3-1.noarch.rpm
    error: Failed dependencies:
            mono(gdk-sharp) = 2.8.0.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono(glade-sharp) = 2.8.0.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono(glib-sharp) = 2.8.0.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono(gtk-sharp) = 2.8.0.0 is needed by openvpn-admin-1.9.3-1.noarch
            mono-core is needed by openvpn-admin-1.9.3-1.noarch

    No ways I checked
    [root@echo ~]# urpmi --noclean mono
    The package(s) are already installed
    [root@echo ~]# urpmi --noclean mono-core
    no package named mono-core

    Eish Wat now? cant we get a link to all the dependencies so I can install them one by one?
    Or sumthing else ?

    JPB

     
    • Sorry by delay (a really big delay) I am monitoring this forum only now :)

      Well, you must install gtk-sharp-2.x to openvpn-admin works properly.