Problems with public key authorisation

2009-11-24
2013-04-16
  • Hello,

    when using id_rsa.pub while connection to aix I receive the following

    lvmbi@chekov:~/.ssh$ ssh -v lvcob@zeus

    OpenSSH_5.1p1 Debian-8, OpenSSL 0.9.8k 25 Mar 2009
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to zeus  port 22.
    debug1: Connection established.
    debug1: identity file /home/lvmbi/.ssh/identity type -1
    debug1: identity file /home/lvmbi/.ssh/id_rsa type 1
    debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
    debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
    debug1: identity file /home/lvmbi/.ssh/id_dsa type -1
    debug1: Remote protocol version 1.99, remote software version OpenSSH_5.2
    debug1: match: OpenSSH_5.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-8
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'zeus' is known and matches the RSA host key.
    debug1: Found key in /home/lvmbi/.ssh/known_hosts:60
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: publickey
    debug1: Trying private key: /home/lvmbi/.ssh/identity
    debug1: Offering public key: /home/lvmbi/.ssh/id_rsa
    Connection closed by 10.1.82.101


    when I remove id_rsa.pub out of ~.ssh. At least the password autorisation works.

     
  • Lissa Valletta
    Lissa Valletta
    2009-12-03

    I have the same problem.     ( I was using 5.2) does not seem to accept the id_rsa keys generated on previous version coming from a  4.5.0.5301  level machine and all running AIX 5.3.    Is this a bug?  We moved back to 5.0 and all worked well.

     
  • hjereza
    hjereza
    2009-12-11

    Thanks guys for posting this!  i am having the exact same problem with the public key.  I believe it's a bug.  We've spent hours trying to figure it out, and then i finally came back here and saw lissav's post.  Can anybody advise?  

    I will try to downgrade openssh.