#161 auth_db skip_version_check param

trunk
closed
modules (179)
5
2011-06-21
2010-09-09
No

Added new parameter to the auth_db module that disables the version number check of the table used in the www_authenticate() call.
We use a table that is hared with other apps and has non-standard column layout thus the version check doesn't make sense. Worse, the version check is for ==, which makes it difficult to go back and forth between two version during an upgrade.

Discussion

  • Bogdan-Andrei Iancu

    Hi Kennard,

    Are you sure something like that is necessary? even if you use a custom table, you can insert the needed version into the "version table".....Also opensips core allows you define the "version" table to be used, so you can use different version tables for differente opensips versions.

    Regards,
    Bogdan

     
  • Kennard White

    Kennard White - 2010-09-17

    Hi Bogdan,
    I added this feature at request of our databbase designer. I'll ask him to respond directly. Your idea of changing the name the version table for different opensips versions is a good one.
    Thanks,
    Kennard

     
  • Aron Rosenberg

    Aron Rosenberg - 2010-09-17

    Bogdan,

    So we added this because our user DB is centralized and adding extra tables with rows is a major pain since the DB credentials we have don't allow for writes to that table.

    We figured when a custom table / DB / columns were being specified it made no sense to need to check the internal schema rev of OpenSIP's tables.

     
  • Bogdan-Andrei Iancu

    • assigned_to: nobody --> razvancrainea
     
  • Razvan Crainea

    Razvan Crainea - 2011-06-21

    I have just applied this patch.

    Thank you and regards,
    Razvan

     
  • Razvan Crainea

    Razvan Crainea - 2011-06-21
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks