OpensSips issue on low bandwidth conditions

2012-02-02
2013-05-09
  • Cristian Dragus

    Cristian Dragus - 2012-02-02

    Our current problem which we encounter on the OpenSIPS server is that we try to create multiple MSRP streams. For some of them we receive the 404 response, because of clients being offline(perfectly normal) in other cases we get a 200 response meaning a MSRP session successfully established but in some cases we receive an “Internal server error” response. In the server logs we have these messages:
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcpconn_connect: tcp_blocking_connect failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcp_send: connect failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:tm:msg_send: tcp_send failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:tm:t_forward_nonack: sending request failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcp_blocking_connect: poll error: flags 1c
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcp_blocking_connect: failed to retrieve SO_ERROR (111) Connection refused
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcpconn_connect: tcp_blocking_connect failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcp_send: connect failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:tm:msg_send: tcp_send failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:tm:t_forward_nonack: sending request failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcp_blocking_connect: poll error: flags 1c
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcp_blocking_connect: failed to retrieve SO_ERROR (111) Connection refused
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcpconn_connect: tcp_blocking_connect failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:core:tcp_send: connect failed
    Jan 31 08:21:27  /sbin/opensips: ERROR:tm:msg_send: tcp_send failed
    3:36 PM
    Jan 30 12:00:44  /sbin/opensips: ERROR:tm:t_forward_nonack: sending request failed
    Jan 30 12:00:49  /sbin/opensips: ERROR:core:_tls_read: SYSCALL error -> (0) <Success>
    Jan 30 12:00:49  /sbin/opensips: ERROR:core:_tls_read: something wrong in SSL: 5
    Jan 30 12:00:49  /sbin/opensips: ERROR:core:tcp_read_req: failed to read

    On the server side we have OpenSIPS server working over TLS, also we have MSRPRelay working on TLS. On the client side we are using sipsimple.

     
  • Bogdan-Andrei Iancu

    Hi,

    The errors in the log mean that opensips tried to forward via TCP/TLS, but the TCP connect was refused on the other side (like no one listening on the destination side, on TCP).

    Regards,
    Bogdan

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks