Implementing TLS with Opensips 1.6

jay
2012-10-04
2013-05-09
  • jay

    jay - 2012-10-04

    hi
    I get the below error when i try to implement TLS on opensips , I see in the log that the certs get loaded but i see this error below :

    Oct  4 01:26:06  DBG:core:tls_init: entered
    Oct  4 01:26:06  ERROR:core:tcp_init: bind(4, 0x81c260c, 16) on 172.16.0.94:5061 : Address already in use
    Oct  4 01:26:06  ERROR:core:tls_init: failed to initialize TCP part
    Oct  4 01:26:06  ERROR:dialog:use_dialog_table: invalid database handle
    Oct  4 01:26:06  DBG:xlog:destroy: destroy module…
    Oct  4 01:26:06  DBG:tlsops:mod_destroy: tlsops module - shutting down…
    Oct  4 01:26:06  DBG:tm:tm_shutdown: tm_shutdown : start
    Oct  4 01:26:06  DBG:tm:unlink_timer_lists: emptying DELETE list
    Oct  4 01:26:06  DBG:tm:tm_shutdown: emptying hash table
    Oct  4 01:26:06  DBG:tm:tm_shutdown: releasing timers
    Oct  4 01:26:06  DBG:tm:tm_shutdown: removing semaphores
    Oct  4 01:26:06  DBG:tm:tm_shutdown: destroying callback lists
    Oct  4 01:26:06  DBG:tm:tm_shutdown: tm_shutdown : done
    Oct  4 01:26:06  DBG:core:destroy_tls: entered
    Oct  4 01:26:06  DBG:core:shm_mem_destroy:
    Oct  4 01:26:06  DBG:core:shm_mem_destroy: destroying the shared memory lock

    Please help!

     
  • Bogdan-Andrei Iancu

    Hi, it seems other application is using the 5061 port, so opensips cannot bind to it.

    Regards,
    Bogdan

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks