#202 Error Setting DB Perms with Postgres

1.5.x
closed-fixed
core (110)
5
2009-10-06
2009-10-02
Anonymous
No

This is OpenSIPS 1.5.3 with a Postgres DB backend.

The opensipsdbctl script(s) assume that all tables have a column, type serial, called "id" However, the DR_RULES & DR_GATEWAYS tables have their main columns called "gwid" & "rulesid" When the script tries to GRANT permissions to the sequences, it fails, as the sequence is called dr_rules_rulesid_seq, rather than the name dr_rules_id_seq.

Changing the column names to just "id" (instead of gwid & rulesid) allows the opensipsdbctl scripts to complete without error.

Discussion

  • Bogdan-Andrei Iancu

    • assigned_to: nobody --> iulia_bublea
     
  • Iulia Bublea

    Iulia Bublea - 2009-10-06

    Hi,

    The bug was fixed on 1.6 and 1.5 by forcing the sequence to dr_rules_rulesid_seq and dr_gateways_gwid_seq.

    Regards,
    Iulia

     
  • Iulia Bublea

    Iulia Bublea - 2009-10-06
    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks