Newbie with warnings and fatal error while creating new index

  • Pam

    Pam - 2013-09-24

    So I'm thinking I completely missed something in the video tutorial for using OSS plugin with wordpress. I got as far as creating the index and ran into 3 warnings and 1 fatal error (see below) and I have no idea why or what they mean. Any help is so appreciated; I was thrilled to find this plugin because it should do everything I have been looking for.

    Warning: CURL failed to execute on URL "http://localhost:8080/schema?use=drtwordpress_index&login=admin&key=9a028415312daf033023af3dfa4f74aa&cmd=indexList" in /home/dianareu/public_html/wp-content/plugins/opensearchserver-search/lib/oss_abstract.class.php on line 169

    Warning: Invalid argument supplied for foreach() in /home/dianareu/public_html/wp-content/plugins/opensearchserver-search/lib/oss_schema.class.php on line 52

    Warning: CURL failed to execute on URL "http://localhost:8080/schema?use=drtwordpress_index&login=admin&key=9a028415312daf033023af3dfa4f74aa&" in /home/dianareu/public_html/wp-content/plugins/opensearchserver-search/lib/oss_abstract.class.php on line 169

    Warning: CURL failed to execute on URL "http://localhost:8080/schema?use=drtwordpress_index&login=admin&key=9a028415312daf033023af3dfa4f74aa&cmd=getSchema" in /home/dianareu/public_html/wp-content/plugins/opensearchserver-search/lib/oss_abstract.class.php on line 169

    Fatal error: Call to a member function xpath() on a non-object in /home/dianareu/public_html/wp-content/plugins/opensearchserver-search/opensearchserver_admin.php on line 44

  • Naveen A.N

    Naveen A.N - 2013-09-25


    The OpenSearchServer PHP client needs the php-curl extension.
    You just have to install it (and probably restart your web server).


  • Pam

    Pam - 2013-10-07

    Thanks for the reply. I am hoping you might expand on it just a bit. I am embarrassed to say I really have no clue how to install the extension. This back-end stuff is not my area of expertise at all. Is this something I do where my site is hosted or on my localhost? I have searched online and found a video for installing the extension in Windows, but I am not using Windows (I have a mac).

  • Naveen A.N

    Naveen A.N - 2013-10-08


    You can use "Macports" to enable the PHP CURL.

    Run this command in the terminal.

    "sudo port install php5-curl".


    Find the php.ini location from this command "php --ini".

    Open the php.ini file and search for the line ";" and remove the semicolon.

    so the line looks like "" save the file and restart the webserver.


    Last edit: Naveen A.N 2013-10-08

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks