Can't retrieve data

mehramilo
2007-01-23
2013-04-26
  • mehramilo

    mehramilo - 2007-01-23

    Hi,

    I'm not able to retrieve any data from the database in my reports.  When I generate a PDF, everything is there (labels, layouts, pictures, etc...) but the query data itself is missing.

    I'm running PostgreSQL 8.1.4 on a dedicated linux server.  I'm using OpenRPT Report Writer on a Windows XP machine and OpenRPT Renderer to create PDF from the .xml files.

    I'm doing very simples reports just to see if it works with simples queries and it doesn't seem to retrieve any date. I tried Fields, Text, etc...

    I have no problem connecting to the database itself with the Renderer.

    Any help?

    Thanks.

     
    • Chris Ryan

      Chris Ryan - 2007-01-31

      We recently had a similar report but it was limited to the Windows NT OS. Qt 4.2.2 appears to have corrected that problem. Are you using one of the precompiled versions or are you compiling yourself, and if so what version of Qt/Compiler? When printing do you only have the problem with pdf prints or do you experience the problem printing to a real printer as well? I am also curious about the query you are using to test with. I have experienced some strange behavior before where the database does not communicate a suitable datatype and the end result is empty fields as you describe.

      Query I have had problems with:
      SELECT 'hello world' AS sometext;

      Same Query above that works as expected:
      SELECT text('hello world') AS sometext;

      I don't know if this is your case but thought I would throw it out there.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks