CentOS 6 not setting VNC password on start

Hussein B.
2011-12-16
2013-04-13
  • Hussein B.

    Hussein B. - 2011-12-16

    I have OpenQRM and CentOS 6 running in a virtual machine. It controls two kvm-storage hosts.

    When I start a VM it turns on fine but does not prompt for a password. Even if I set the password after it has started.

    I added ",password" option to the vnc parameter in the qemu-kvm command. It prompts for a password then on start-up but does not accept the original password. If I set the password using the binary or web interface it works until the qemu-kvm command is initiated again.

    Dec 15 19:53:53 two root: openQRM engine: Running as root cmd : /usr/share/openqrm/plugins/kvm-storage/bin/openqrm-kvm-storage-vm start -n hbdesktop -u xxxxxxxx -p xxxxxxxx
    Dec 15 19:53:53 two kvm-storage plug-in: kvm_storage_lock : Aquired the lock
    Dec 15 19:53:53 two root: KVM vm hbdesktop starting up …
    Dec 15 19:53:53 two lldpad: evb_ifdown:port tap0 remove failed
    Dec 15 19:53:53 two lldpad: vdp_ifdown:tap0 vdp data remove failed
    Dec 15 19:53:53 two kernel: device tap0 entered promiscuous mode
    Dec 15 19:53:53 two lldpad: evb_ifdown:port tap0 remove failed
    Dec 15 19:53:53 two lldpad: vdp_ifdown:tap0 vdp data remove failed
    Dec 15 19:53:53 two kernel: br2: topology change detected, propagating
    Dec 15 19:53:53 two kernel: br2: port 2(tap0) entering forwarding state
    Dec 15 19:53:55 two root: /usr/share/openqrm/plugins/kvm-storage/sbin/openqrm-kvm-storage-monitord: Gathering resources-information
    Dec 15 19:53:55 two kvm-storage plug-in: kvm_storage_lock : Released the lock
    Dec 15 19:53:55 two root: File descriptor 6 (pipe:) leaked on pvscan invocation. Parent PID 5346: /bin/bash File descriptor 6 (pipe:) leaked on vgscan invocation. Parent PID 5346: /bin/bash File descriptor 6 (pipe:) leaked on lvscan invocation. Parent PID 5346: /bin/bash File descriptor 6 (pipe:) leaked on lvchange invocation. Parent PID 5346: /bin/bash which: no kvm in (/usr/bin:/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin) which: no qemu-kvm in (/usr/bin:/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin) 2011/12/15 19:53:53 socat E connect(3, AF=1 "/var/run/openqrm/kvm-storage/kvm.hbdesktop.mon", 48): Connection refused

    It appears that socat is unable to connect.

    Running "echo "change vnc password $KVM_VM_VNCPASSWORD" | socat stdio unix:/var/run/openqrm/kvm-storage/kvm.$VM_NAME.mon" connected and set the password correctly.

    I would appreciate any recommendations on where to begin implementing a solution.

     
  • Hussein B.

    Hussein B. - 2011-12-16

    Also, socat and procmail were not installed automatically when installing OpenQRM. I had to install them after using yum.

     
  • Hussein B.

    Hussein B. - 2011-12-16

    I fixed it.

    I increased the sleep time from 1 to 10. Also I needed to keep the vnc password option set on the qemu-kvm command.

    I hope this helps!

     
  • Matt

    Matt - 2012-01-15

    cool, thanks!

    many thanks and have a nice day,

    Matt Rechenburg
    Project Manager openQRM

     

Log in to post a comment.