Image-shelf on "Put" issues

junix88
2012-03-01
2013-04-13
  • junix88

    junix88 - 2012-03-01

    Hello,

    Anyone encountered issues on Image-shelf where when we deploy or  "Put"  Server Template from Image-Shelf being selected or "get", created LVM-NFS images is nowhere to be found in the LIST  of Available LVM-NFS-Images to 'put' the template when we suppose to select openQRM Image to populate the server template to the logical volume. I observed this especially when the number of images grows (e.g. more than 50 images).

    Any help is very much appreciated.

    Thank you.

    junix

     
  • JonD9

    JonD9 - 2012-03-01

    When you look at it via command line does do you show the storage being allocated?

     
  • junix88

    junix88 - 2012-03-02

    Hello lordslamm,

    Thanks for the reply. Yes, its there - lv being created shows (via exportfs -v) and I also checked /etc/exports its also there obviously. What I did because I can't "put" or populate the filesystem of the Server Template in the Image-Shelf  to the image I created, I used rsync + ssh from running KVM VM (bare metal via virt-manager) to the /vg/lv. BUT the problem of using this is for the normal user because I want it to be easy for them to deploy Server Template into the image being created. I don't know if this is  a bug because in my case I have 53 images in the Image List BUT when you go to Deployment -> Image-shelf -> Import -> Select (Image-Shelf) ->  get ( Server Template) then "put", I only see the list of images being created only until ID 28 the rest after 28 is not there. I tried to create a new image (Lvm Storage Server (Nfs) type) just to test if it shows in the Image list  when I "put" the Server Template BUT STILL the image that I created is not there. I'm confuse if why is it all the images that I created after 28 is not in the list of images when we "put" or populate the filesystem in the Server Template.

    Do hope you could help me to resolve this issues or you may try to duplicate my incidents maybe you could find ways to address the problem.

    Thanks lordslamm.

    junix

     
  • Matt

    Matt - 2012-03-03

    Hi lordslamm, Hi Junix,

    did you tried to set the table limit to e.g. 50 and refresh on top of the lvm-nfs-image table ?

    many thanks and have a nice day,

    Matt Rechenburg
    Project Manager openQRM

     
  • junix88

    junix88 - 2012-03-03

    Hello Matt,

    Yes I did it set to 50 and refresh several times BUT still images that newly been created doesn't shows.

    Thanks a bunch Matt + have a good one.

    junix

     
  • junix88

    junix88 - 2012-03-13

    Hello there,

    If anyone encountered this issues and has a solution please help.

    Thanks.

     
  • Matt

    Matt - 2012-05-01

    Hi Junix,

    just found time to test it. It is a bug. Please open a ticket in our tracker about it. We will fix it for the next release.

    many thanks and have a nice day,

    Matt Rechenburg
    Project Manager openQRM

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks