Open QRM Installation Error

Jagan RYM
2011-11-30
2013-04-13
  • Jagan RYM

    Jagan RYM - 2011-11-30

    Hi,

    I have followed "Setup_your_own_openQRM_Cloud_on_Ubuntu_Lucid_Lynx.10052010.pdf" and tried setting up open qrm on ubuntu 11.10.

    All went fine till make install but I get below error when I try make install.

    cp: cannot stat `/root/openqrm/trunk/src/../buildtmp/openqrm-build/initroot/bin/dbclient': Not a directory
    > make: ***  Error 1
    > cd: 1: can't cd to ./sbin
    > cd: 1: can't cd to ./doc
    > cd: 1: can't cd to ./include
    > cd: 1: can't cd to ./etc
    > cd: 1: can't cd to ./bin
    > cd: 1: can't cd to ./tftpboot
    > cd: 1: can't cd to ./plugins
    > make: ***  Error 2

    Appreciate the help

     
  • David Champion

    David Champion - 2011-11-30

    I have solved this problem on ubuntu 11.10
    i. install dropbear with apt-get
    ii. copy /usr/bin and /usr/sbin to ~/buildtmp/openqrm-build/initroot
    iii. copy /usr/lib/dropbearconvert to ~/buildtmp/openqrm-build/initroot/bin, then done

    I met this problem on Fedora 16 and Debian Squeeze too, this solution may work on both RHEL-like and Debian-like Linux

     
  • DPWV

    DPWV - 2011-12-13

    It works too, when u "make deb" (a complete package / read the man-page) and install it from this deb package with dpkg -ii %deb-package name% (on Ubuntu 11.10).
    But nice solution. When i where earlier in this forum, i dont take so much time to get it work :)

    Only have this problems on my Notebook with Ubuntu. I get no problems with a normal Server and Debain 6.0.3 64bit.

     
  • ScottZ

    ScottZ - 2011-12-26

    dchampion,
    Thank you very much for the pointers!  For others having problems installing openqrm on Ubuntu 11.10, here is a step by step command list to get it compiled and installed.

    tar xzf openqrm-4.9.tgz
    cd openqrm-4.9/src
    mkdir -p ../buildtmp/openqrm-build/initroot
    cp -a /usr/bin ../buildtmp/openqrm-build/initroot
    cp -a /usr/sbin ../buildtmp/openqrm-build/initroot
    cp  /usr/lib/dropbear/dropbearconvert ../buildtmp/openqrm-build/initroot/bin/
    wget http://matt.ucc.asn.au/dropbear/releases/dropbear-0.53.1.tar.gz
    mv dropbear-0.53.1.tar.gz ../buildtmp/openqrm-build/dropbear/source/
    make
    make install

     
  • ScottZ

    ScottZ - 2011-12-26

    Sorry, above post was sent to the wrong thread!

     
  • ScottZ

    ScottZ - 2011-12-26

    dchampion,
    Thank you very much for the pointers!  For others having problems installing openqrm on Ubuntu 11.10, here is a step by step command list to get it compiled and installed.

    tar xzf openqrm-4.9.tgz
    cd openqrm-4.9/src
    mkdir -p ../buildtmp/openqrm-build/initroot
    cp -a /usr/bin ../buildtmp/openqrm-build/initroot
    cp -a /usr/sbin ../buildtmp/openqrm-build/initroot
    cp  /usr/lib/dropbear/dropbearconvert ../buildtmp/openqrm-build/initroot/bin/
    wget http://matt.ucc.asn.au/dropbear/releases/dropbear-0.53.1.tar.gz
    mv dropbear-0.53.1.tar.gz ../buildtmp/openqrm-build/dropbear/source/
    make
    make install

     
  • Matt

    Matt - 2012-01-15

    Hi again szettervall,

    good and please do not forget to run "make start" after "make && make install"

    many thanks and have a nice day,

    Matt Rechenburg
    Project Manager openQRM

     
  • slugslice

    slugslice - 2012-03-16

    Hi Matt.

    I am getting the following error when I try to install openQRM on Linux Mint 12:

    datacenter01 src # make install
    Creating the openqrm-client boot-service package
    cp: cannot stat `/home/administrator/Downloads/openqrm-4.9/src/../buildtmp/openqrm-build/initroot/bin/dbclient': Not a directory
    make: ***  Error 1
    cd: 1: can't cd to ./doc
    cd: 1: can't cd to ./bin
    cd: 1: can't cd to ./plugins
    cd: 1: can't cd to ./include
    cd: 1: can't cd to ./etc
    cd: 1: can't cd to ./sbin
    make: ***  Error 2

    What could be wrong?

    Thanks.

    Regards,

    Eric

     
  • Matt

    Matt - 2012-05-01

    Hi Eric,

    dropbear did not compiled correctly on your system.
    I would recommend to try it on one of the supported Distributions (Debian/Ubuntu/CentOS)

    many thanks and have a nice day,

    Matt Rechenburg
    Project Manager openQRM

     
  • rkaluta

    rkaluta - 2012-05-24

    While trying to compile "make" on ubuntu 12.04 these errors have surfaced

    ############################################
    networking/ntpd.c:1888:3: warning: format not a string literal and no format arguments
      CC      networking/ping.o
      CC      networking/pscan.o
      CC      networking/route.o
      CC      networking/slattach.o
    networking/slattach.c: In function 'slattach_main':
    networking/slattach.c:241:9: warning: ignoring return value of 'system', declared with attribute warn_unused_result
      CC      networking/tcpudp.o
    In file included from /usr/include/linux/sysctl.h:25:0,
                     from /usr/include/linux/netfilter.h:6,
                     from /usr/include/linux/netfilter_ipv4.h:8,
                     from networking/tcpudp.c:37:
    /usr/include/linux/kernel.h:12:8: error: redefinition of 'struct sysinfo'
    include/libbb.h:105:8: note: originally defined here
    make: ***  Error 1
    make: ***  Error 2
    make: Leaving directory `/home/myhomedir/openqrm-4.9/trunk/buildtmp/openqrm-build/busybox/busybox-1.18.5'
    make: Entering directory `/home/myhomedir/openqrm-4.9/trunk/buildtmp/openqrm-build/busybox/busybox-1.18.5'
      CC      networking/tcpudp.o
    In file included from /usr/include/linux/sysctl.h:25:0,
                     from /usr/include/linux/netfilter.h:6,
                     from /usr/include/linux/netfilter_ipv4.h:8,
                     from networking/tcpudp.c:37:
    /usr/include/linux/kernel.h:12:8: error: redefinition of 'struct sysinfo'
    include/libbb.h:105:8: note: originally defined here
    make: ***  Error 1
    make: ***  Error 2
    make: Leaving directory `/home/myhomedir/openqrm-4.9/trunk/buildtmp/openqrm-build/busybox/busybox-1.18.5'
    -> found component pciutils (pciutils-3.1.7.tar.gz) already downloaded
    -> Found pciutils-3.1.7/pcimodules already in the build-cache
    -> Skipping compilation, taking the ready built component from the cache
    -> found component dropbear (dropbear-2012.55.tar.gz) already downloaded
    -> Found dropbear-2012.55/dropbear already in the build-cache
    -> Skipping compilation, taking the ready built component from the cache
    cp: cannot stat `/home/myhomedir/openqrm-4.9/trunk/src/./../buildtmp/openqrm-build/busybox/busybox-1.18.5//_install/*': No such file or directory
    ############################################

    I have tried the original dropbear and busybox and the newer dropbear-2012.55 and busybox 1.18

    I suspect that this is the reason any lxc VMs will not start.
    Can you point me in the right direction ?
    Is openqrm installable on ubuntu 12.04 ?

    Thanks,
    rkaluta

     
  • Matt

    Matt - 2012-06-04

    Hi again,

    openQRM 4.9 builds and works fine on Ubuntu up to 10.10.
    Next version will build + work fine also for latest Ubuntu.

    many thanks and have a nice day,

    Matt Rechenburg
    Project Manager openQRM

     

Log in to post a comment.