Can not deploy windows xp using openQRM 5.0

Help
leo kaka
2012-10-24
2013-04-13
  • leo kaka

    leo kaka - 2012-10-24

    Hi everybody, i'm using openqrm for the first time. I'm running openqrm on CentOS 6.3

    I using the document named how to deploying windows system on centos 5.5 (a liitle bit out of updated).

    All of the installation is ok, but when i transfer the local disk of winxp computer to my iscsi storage, i realized that a image for this winxp was created automatically. When I using this image to create an appliance and remove local hard disk from my winxp computer, this winxp computer can get ip, boot from network … but it show that no operating system is installed and it can not continue. Please help!

    I think that the winxp comp can not specify the image so it can not boot. Any ideas?

    Thank you!

    (Sorry for my bad english! :()


     
  • Matt

    Matt - 2012-11-07

    Hi leokaka,

    it seems the iscsi parameters are not specified correctly in the dhcpd.conf of openQRM.
    Did you start the Appliance ? -> starting the appliance will set the iscsi parameters in the dhcpd.conf.

    Please check :  /usr/share/openqrm/plugins/dhcpd/etc/dhcpd.conf

    many thanks, have a nice day and enjoy openQRM 5.0,

    Matt Rechenburg
    Project Manager openQRM

     
  • leo kaka

    leo kaka - 2012-11-26

    Thanks Matt, but the problem isn't solved yet!
    I checked the dhcpd.conf file and here the result:

    The root path was configured correctly!
    But the result is:

    The strange thing is that the IP of net0, it is 192168.1.64 but the openqrm server is 192.168.1.70. Is this the problem? And how can I fix it? Thank you!
    PS: I'm running openqrm on another system, using openqrm4.9 and ubuntu 10.04.

     
  • leo kaka

    leo kaka - 2012-11-27

    Some more information:
    I'm using openQRM 4.9, which was installed on Ubuntu 10.04 (I'm running this system on VMware).
    I'm going to deploy windows XP like in the Deploy Windows XP on CentOS 5.5.
    Everything is OK but at the step Start Appliance and boot the idle resource (this resource is on VMWare too) using the image on openQRM server, I had a problem that the resource cannot detect the image root path.
    I've check the dhcpd.conf and the config is all right (like the picture above). I try to reboot so many times but the problem is still the same! I check the .vmx config file (follow this page: http://etherboot.org/wiki/sanboot/winnt_iscsi_debug) but the value of scsi0.present="TRUE" already.
    Thank for any help!

     
  • Matt

    Matt - 2012-11-27

    Hi leokaka,

    from your openQRM dhcpd the system "should" get the 192.168.1.1 ip address.
    It actually gets 192.168.1.64!

    That means it seems you have a second dhcpd server in your network answering the requests before the openQRM dhcpd does. 2 dhcpd server in one network causing troubles.
    -> please turn off your second (other) dhcpd server and it wll start to work

    many thanks and have a nice day,

    Matt Rechenburg
    Project Manager openQRM

     
  • leo kaka

    leo kaka - 2012-11-29

    Thanks Matt, that is the problem. My router is a dhcp too so when I change the NIC in the vmware for the openQRM server and the winxp client, everything is OK now.

    But still a liitle problem with cloud plugin:

    I've set the image of XP to all:

    But when i log in a user to test, I can not file the image?

    Please help!
    Many thanks!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks