SourceForge has been redesigned. Learn more.
Close

any success compiling w/gcc 4.x, not 3.x ???

Help
BrettC
2007-05-25
2013-04-16
  • BrettC

    BrettC - 2007-05-25

    Has anyone been able to compile PNL with gcc/g++ 4.x, rather than 3.x?  If not, any informed opinions about the issues?

    Like others, I've had success compiling with 3.x, but I'm concerned about future compatibility.  I'm new to PNL and I'm hoping to use and contribute to this library, but I want to be able to use it in the future too!  If someone has any good ideas about why it won't work yet, I'm willing to work on it, but I'd like to have an idea of what the problems are before I commit.

    Thanks,
    Brett

     
    • Zeppe

      Zeppe - 2007-06-26

      Yes, I've successfully compiled it under gcc 4.1.2. Some little modifications are needed. I'll try to post a patch that fixes the errors.

       
    • BrettC

      BrettC - 2007-07-07

      I found the patch (in Tracker --> Patches).

      Thanks for doing this!!

       

Log in to post a comment.