Dear All,

I use a arm-none-eabi tool chain that contains Linaro gdb 7.6-2013.05 to work on a STM32F429 (cortex m4) via a stlinkv2

Till now I have been using openocp 0.7 that works very well for me.

A few days ago, I downloaded the 0.8 version : I would need to use the trace feature you added in this version

When compiling it, I ran into the libftdi issue : it claimed not finding it on my machine. Thanks to your mailing list, I overcame that: my debian wheezy did not have pkg-config installed. Compilation is all ok now.

I can launch it. I use this: /opt/openocd080/bin/openocd -f /opt/openocd080/tcl/board/stm32f429discovery.cfg

    Open On-Chip Debugger 0.8.0-rc1 (2014-04-12-08:02)
    Licensed under GNU GPL v2
    For bug reports, read
        http://openocd.sourceforge.net/doc/doxygen/bugs.html
    srst_only separate srst_nogate srst_open_drain connect_deassert_srst
    Info : This adapter doesn't support configurable speed
    Info : STLINK v2 JTAG v17 API v2 SWIM v0 VID 0x0483 PID 0x3748
    Info : using stlink api v2
    Info : Target voltage: 2.881690
    Info : stm32f4x.cpu: hardware has 6 breakpoints, 4 watchpoints

I can connect to it using a telnet session without issue.

But once my gdb connects to it, i get this:

    Info : accepting 'gdb' connection from 3333
    Info : device id = 0x10036419
    Info : flash size = 2048kbytes
    undefined debug reason 7 - target needs reset
    target state: halted
    target halted due to debug-request, current mode: Thread
    xPSR: 0x01000000 pc: 0x080001ac msp: 0x20030000
    Error: gdb requested a non-existing register
    Info : dropped 'gdb' connection
  
I did the same with the last Release Candidate (Open On-Chip Debugger 0.8.0-rc2) and I get the same error.

I went through your mailing list without finding something that could help me.

If someone could help me on that?

Thank you,
Thierry