Hello,


I am trying to use the OpenObex Server with no luck.  I have both programmed the OpenObex API in my own app and used the obex_test tool provided in openobex-apps, with the same result.

For the familiar obex_test program -

I run:
obex_test -b 00:00:00:00:00:00 10

I then start the server using 's' and as expected the server waits.  Except when I try to connect from another device it tells me "Sending business card failed" or other sparratic error messages.  I have registered an Obex Object Push Service record with sdptool, and I don't know what else it could be.

I can do an hciconfig and see the number of packets seen (RX and TX), and after I try to make a connection from another device, the RX and TX values go up by 25-28 every time, so I know something is going on.  But as for inside the program, I have ran through a debugger and everything, the callback function is never called, it just seems like openobex is not doing anything.  I also have recompiled openobex defining OBEX_DEBUG as 2 to see if I get any extra debug messages, but when the server is running, I get nothing.

Am I missing something?  The client works fine, I can send vcf's from Linux to my pda no problem.  


Thank you very much for your help,
Scott Meesseman