SourceForge has been redesigned. Learn more.

Compiling obexserver fail

  • Claudio Miranda

    Claudio Miranda - 2003-08-17

       Hi, I am trying to compile obexserver.c to receive files from Nokia 3650 over bluetooth.

       My system:
       - RH 9
       - Kernel 2.4.21-mh2
       - OpenObex-apps and OpenObex installed at /usr/local/stow/openobex-apps and  /usr/local/stow/openobex, both soft linked to /usr/local. So OpenObex (and apps) are available to all systems through /usr/local/include/openobex and /usr/local/lib
       Following some articles available on internet I am trying to compile obexserver.c

    $ cc  -o obexserver obexserver.c libmisc.a -lopenobex
    /tmp/ccpKCLyt.o(.text+0x5e): In function `main':
    : undefined reference to `btobex_accept'
    collect2: ld returned 1 exit status

        Do you known anything can help me ?

    Thank you for your time.

    Claudio Miranda

    • john woods

      john woods - 2007-07-02

      I ran into this too. I fussed with it for a while, finally
      gcc -Wall -shared obexserver.c -lbluetooth -lopenobex -o obexserver
      produced something.

    • john woods

      john woods - 2007-07-02

      It segfaults when I run it. I guess I will have to try and figure out how to tell the linker we are using static libs when I compile.


Log in to post a comment.