obex_test server, obexftp, & T68i over bluez

  • Ross Manges

    Ross Manges - 2003-08-12


    I'm having trouble 'sending' anything from my T68i to the obex_test in server mode.  However, I can send "vcf" files from from my PC to my t68i without any problems using the obex_test program. I basically followed the instructions on this page http://www.unrooted.net/openSource/bluez/t68i.html which were quite helpful.  So I feel that my bluetooth usb dongle is setup correctly and I have shown that I have some sort of connectivity between my T68i and my PC.

    In any case, when I try to setup open_test in server mode, and try to send a "contact" from my T68i via bluetooth, it fails.  For example:

    First I load the obex test program

    % ./obex_test -b 00:00:00:00:00:00 10
    Using Bluetooth RFCOMM transport
    OBEX Interactive test client/server.
    > s

    and then nothing else appears in the terminal.

    If I try to send a "contact" from my phone via bluetooth, it will fail.

    I have also tried using obexftp with the "-i" option to retrieve information about the phone.  The phone recieves the request, and prompts me to "accept", "add to pairing", or "decline" the request.  If I choose "accept" or "add to pairing", it asks me for a password.  Does anybody know anything about this?  Is it a password that is set within obexftp, or is it a security feature of my phone and I just don't know what the password is?

    I've tried searching on these topics and this is as far as I've got.  I'd really like to be able to sync the address book between my PC and my T68i.  If anybody has any ideas or can point me in the direction of the proper documentation it would be most appreciated.  Thanks!

    p.s. - I'm running:
    Gentoo 1.4
    and the bluez bluetooth stack
    (everything is from a gentoo ebuild)
    ...and an IOGear (broadcomm) bluetooth usb dongle.

    • Ross Manges

      Ross Manges - 2003-08-13

      Since I posted the previous msg, I've learned that the pin can be set in /etc/bluetooth/pin and that I  need to launch hcid and sdpd, something I somehow overlooked.  Once I did that, I was able to syncronize my address book using 'multisync', so I'm set for now.


Log in to post a comment.