Install OpenMedis

Help
2009-04-26
2013-04-29
  • Ellis Fuenmayor

    Ellis Fuenmayor - 2009-04-26

    Hi,

    Thank you for make and share OpenMedis.

    I want to install OpenMedis but i have some problems.

    -------------------------------------------------------------------
    These are my actual settings:
    -------------------------------------------------------------------

    a) Database:

          "Database" => "angiosc_openmedis",
            "Host" => "localhost",
        "Port" => "3306",
            "User" => "angiosc_admin",
            "Password" => "15xxxxxxxxxx",

    b) I have a online instalation for OpenMEDIS in: http://om.angios.com

    c) The directory for openmedis in my hosting server is:

    ....home/angiosc/public_html/OpenMEDIS

    d) PHP version is 5.2.4

    e) The name of  database is: angiosc_openmedis. I created the tables with your script

    f) My Browser is:  Mozilla Firefox

    -------------------------------------------------------------------------------------------
    The first time that I tried to enter to OpenMEDIS (http://om.angios.com)
    I got these errors:
    -------------------------------------------------------------------------------------------

    Could not connect to the server localhost

    Please check your settings in file: Common.php

    host: localhost

    host: root

    host:

    host: openmedis

    Access denied for user 'root'@'localhost' (using password: NO)

    No database called openmedis was created yet.

    Initializing openMEDIS database.......done

    Creating tables..........

    1045: Access denied for user 'angiosc'@'localhost' (using password: NO)

    Login
        
    Login    
    Password    

    Remember me

    --------------------------------------------------------------------------------------------------------------
    Ok, After that  I changed your database settings for my own database settigns in the command.php
    --------------------------------------------------------------------------------------------------------------

          "Database" => "angiosc_openmedis",
            "Host" => "localhost",
            "User" => "angiosc_admin",
            "Password" => "15xxxxxxxxxx",

    ---------------------------------------------------------------------------------------------------------------
    When I tried to enter  again I only got a blank page.
    Can you help me?.
    ---------------------------------------------------------------------------------------------------------------

    Regards,

    Ellis

     
  • Lau Yew Nen

    Lau Yew Nen - 2013-01-27

    Dear ellisalberti, I have the same problem like yours. Hopefully someone can help us.

     
  • claudio zaugg

    claudio zaugg - 2013-01-28

    Hi Yewnen,

    Not quite sure, what the problem is but just a note: The database settings are defined in Common.inc.php. One setting is for the login database and one for the actual database.

    I hope this helps.

    Claudio

     
  • Lau Yew Nen

    Lau Yew Nen - 2013-01-29

    Dear Claudio
    Thanks for your soonest reply. There is no problem if the installation is done at own computer. But we will have problem if we installing OpenMEDIS at the web host.

    It is impossible for me to put in the database name ($db & $login_db) as openmedis because the server will automatically insert our account username before the db name. For this case, the server automatically insert duorg_ right before openmedis. I did change the db names in common.inc.php, but still not working.

    My OpenMEDIS installation site: http://1du.org/OpenMEDIS
    The username and password are still remains as default, I can't change them because the error is there.

    Below are the changes I made in the common.inc.php for the db variables:

    $db = "duorg_openmedis"; // Default database - if not specified other for user
    $login_db = "duorg_openmedis"; // Common database for login
    $host = "localhost"; // hostname
    $port = "3306"; // Port 3306 = mySQL
    $user = "duorg_openmedis"; // user for database
    $password = "1234azsxd"; // password for access to database
    ==========================================================================================

    Looking forward for your advise.

     
  • claudio zaugg

    claudio zaugg - 2013-01-29

    Hi,

    I think I know the problem: I  the latest versions, each user can have different database to connect to after login.

    This is stored in the table: login in the field DefaultDB. Change this field tor the user "admin" to your database name and it should work.

    With best,
    Claudio

     
  • Lau Yew Nen

    Lau Yew Nen - 2013-01-29

    Dear Claudio,
    Thanks. I'm sorry, I didn't get what you mean. Please enlighten me…

     
  • Lau Yew Nen

    Lau Yew Nen - 2013-01-29

    Dear Claudio
    I get what you mean, i renamed the "openmedis" in DefaultDB to "duorg_openmedis" via phpMyAdmin.
    It works like a charm… Thanks for your great help. Glacias.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks