#2 problems loading pppol2tp plugin

closed
nobody
None
5
2014-08-17
2005-08-25
Anonymous
No

Hi,

I am having problems starting openl2tpd (0.8) with the
pppol2tp.so plugin. When running 'openl2tpd -f -p
pppol2tp.so', it reports:

'/usr/lib/openl2tp/pppol2tp.so: undefined symbol:
generic_establish_ppp. Couldn't load plugin pppol2tp.so'

I am able to start it without specifying plugins and
successfully create tunnels, but I wish to tunnel a
pppd connection through the tunnel. I have tried running:

'pppd debug noauth nodetach plugin ./pppd/pppol2tp.so
pppol2tp 269', but get 'socket invalid' (I'm not sure
if that is the correct socket, I found that in the
pppol2tp.c file).

My pppd source has 'generic_establish_ppp' at
/usr/include/pppd/pppd.h and everything compiles ok.
I have the following ppp modules loaded:

ppp_generic
ppp_synctty
ppp_async
pppol2tp
pppoe
pppox
ppp_deflate

System info: Debian 3.1
ppp version 2.4.2
kernel 2.4.27 patched with openl2tp-0.8

Any help greatly appreciated.

regards,

Campbell

Discussion

  • Nobody/Anonymous

    Logged In: NO

    The version of pppd is in fact 2.4.3, not 2.4.2 as I wrote.
    I am able to get the pppol2tp.so library to load when I run:
    'pppd debug noauth nodetach plugin pppol2tp.so pppol2tp
    269', but it reports:
    'Given FD for PPPoL2TP socket invalid (Bad File Descriptor'

    Cheers

     
  • James Chapman

    James Chapman - 2005-09-10

    Logged In: YES
    user_id=1092414

    Sorry for taking so long to reply.

    The -p argument to openl2tpd is used to load openl2tp
    plugins - you are trying to load the pppd plugin into
    openl2tp. Just remove the -p argument.

     
  • James Chapman

    James Chapman - 2005-09-10
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks