Unable to configure settings.ini

2010-10-21
2013-04-25
  • Steve Klund

    Steve Klund - 2010-10-21

    Hello Folks!
    I am having a similar problem that shawyn "Help with initial setup" is having.
    I am running Centos 5.5, apache, mysql 5.  I have a joomla site and a moodle site running flawlessly.  I placed the openit folder in my /var/www/html …..  created a DB "myopenitdb" with a unique user.
    Edited the settings.ini including this line:
    Debug = True         for debugging [but appears to have to effect as I cannot find any debugging logs)

    mysql://openitadmin:password@localhost/openit
    changed permission to this settings.ini file to 777 to see if it would help

    When I goto localhost/openit/tools/setup.php  (as described in install doc)

    I get this displayed:

    OpenIT Setup Error
    Error:  Cannot connect to database.
    Please check database settings in inc/settings.ini

    So,   if someone can direct me to my mistake, I'd really appreciate the help.

    Thanks,

    Steve K

     
  • Nick Vrtis

    Nick Vrtis - 2010-10-21

    Your note says

    /var/www/html ….. created a DB "myopenitdb" with a unique user.

    , but your settings says you are trying to connect to the

    openit

    database. 

    I think you need to change the settings.ini to

    database=mysql://openitadmin:password@localhost/myopenitdb

    Nick

     
  • Steve Klund

    Steve Klund - 2010-10-21

    Nick,

    Thanks for the reply.

    That was my typo…………. the db is named openit …………………….. the lingering 'db' is habit as I use sybase for other things…

    The database built in phpmyadmin is:  openit

    Sorry for the confusion

    Steve

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks