Can't play encrypted file

  • MoHaX

    MoHaX - 2006-08-25

    Encryption process goes fine.
    When I try to play encrypted mp4 file, nothing happened at all.
    Debug version of DRMPlugin+mp4player doesn't start also, additionaly I get debugger popup with memory leaks warning.

    I use VC6 SP6 under Windows XP SP2 to compile encoder and player.

    Could anyone post solution?

    • piano

      piano - 2006-08-31

      I got the same problem. mp4player.exe did neither play encrypted nor not-encrypted mp4-files, --help or --version parameters are ignored.
      I found no debug.log or drmplugin.log which can possible point me to a solution. It seems mp4player is missing some core-libraries. I still trying to get it work.


    • Danijel Kopcinovic


      Thanks for checking out and testing our code.

      About the problems you've encountered: first of all, are you running the encoder/player from Visual Studio or from console? If running from VS, everything should be set up and working, assuming that the build went ok. If running from a console, then perhaps you forgot to copy some of the necessary DLLs to the working directory.

      Anyway, you should check out the drmplugin.log file after encoding to see if it indicates some error. If not, then it's probably something with the parameters and configuration file for the mp4player. Can you send me your full console line for encoding/playing and configuration files (EncoderInfo.xml/PlayerInfo.xml) and I'll try to check it out?

      Danijel Kopcinovic

    • piano

      piano - 2006-09-11

      Thanks for reply and dealing with this problem.
      I'm running both apps from console and have tested it now directly from VS. The encoder works well if i start it from VS, but the player gives a "Memory leaks detected" when starting from VS. That must be the problem ... i use Windows XP Home and VS 6.0, nothing special.

      The DLLs are in \Demo\mpeg4ip\mpeg4ip-1.5\DRMPlugin, as described in Your doc. I build the DRMPlugin-Project with Debug Configuration.

      Enconding works well, heres the drmplugin.log:
      OpenIPMPDOIContentInfoManager::GetContentInfo: ok...
      OpenIPMPKeyManager::CreateAndStoreKey: ok...
      OpenIPMPKeyManager::AddLicense: ok...

      The memory leaks must be the problem, but here are the config-files and app-parameter.
      <!-- Rights host address-->
      <!-- OMA silent header-->
      <!-- OMA preview header-->
      <!-- OMA content URL header-->
      <!-- OMA content version header-->
      <!-- OMA content location header-->
      <!-- OpenIPMP p12 file path-->
      <!-- <P12FilePath>nico.p12</P12FilePath>-->
      <!-- OpenIPMP random number file-->
      <!-- Content title, used by DOI content info manager-->
      <!-- DOI content information-->
      <doi:KernelMetadata xmlns:doi="">
         <Agent sequence="1">
           <NameValue>Matt Witte</NameValue>
         <Agent sequence="2">
           <NameValue>Persons Name Here</NameValue>

      encoding parameters:
      mp4creator -E -W=EncoderInfo.xml -X=UserName;nico -X=UserPass;xx -X=License;nico;2005-08-31;2007-08-31;ODRL -Y=openipmp;bfs orbit.mp4 enc-orbit.mp4.

      mp4player -W=PlayerInfo.xml -X=UserName;nico -X=UserPass;xx enc-orbit.mp4.

      <!-- OpenIPMP p12 file path-->
      <!-- OpenIPMP random number file-->
      <!-- OMA device registration database file-->
      <!-- OMA device rights database file-->
      <!-- OMA device certificate file-->
      <!-- OMA device private key file-->
      <!-- OMA device CA certificate file-->
      <!-- OMA device manufacturer-->
      <!-- OMA device model-->
      <!-- OMA device version-->
      <!-- OMA device ROAP version-->
      <!-- OMA device caching database indicator-->
      <!-- OMA device trusted CA certificate file-->
      <!-- OMA device supported algorithm-->
      <!-- OMA device supported algorithm-->


    • piano

      piano - 2006-09-11

      The memory leaks warning only appears when i build everything with debug configuration, with release config i can start both apps from VS, but the player  still not react to given paramaters.


    • Danijel Kopcinovic


      Since encoding went without problems, DRM part is working correctly. This means that something is wrong with the mp4player part. You indicated that you cannot play a plaintext file either. Can you check out the output of mp4player when you try to play a plaintext file? It should be in stdout.log or you can see it in Visual Studio output window if you run app from Visual Studio. Or try playing another file. It happened to us before that some files are badly encoded, or with unknown codec, so mp4player cannot play them.

      About the memory leaks: we have added the memory leak check to test if our code generates any. The check is set up only for debug version, that is why you cannot see it in release version. The leak sometimes happens (in mpeg4ip), when the play fails, as in your case. So you can ignore it. :)


    • piano

      piano - 2006-09-12

      Thanks for help, Danijel. I'm pretty sure to did all as described in Your doc, actually with no build error. The problem is: mp4player doesnt give any(!) output. Neither when i start it with --version, --help nor DRM-parameters. There is no .log-file created by the player. If i start the player from VS, i get this memory leaks warnings, which i dont care about from now on ;)
      I tried many different media-files till now, always no reaction. mp4creator works well, it produces even log-files. There must be something wrong with the mpeg4ip player ... i tried to build the latest "standalone" mpeg4ip, but its seems to be thought for VS .net, which i dont have.

    • Danijel Kopcinovic

      This is strange. If build went without errors, then at least something should be written as mp4player output.
      Did you try to run it from Visual Studio and look at the output in VS output window? At least it should write down about adding plug-ins. If mp4player cannot find plug-ins for mp4 file, then it won't play anything, but it should write out about not being able to find appropriate plug-in. Please try this, and send me the output.

    • piano

      piano - 2006-09-13

      Hi Danijel, if i try to start mp4player from VS, it shows a console for one second and then the memory leaks warnings. Nothing else, no adding plug-ins appears and no log-files are created, no output. Started from VS, mp4creator shows a warning like "file to encrypt not found" because i dont give parameters ... this works correctly, so the DRM-plugins should be at the right place (for mp4creator). Both projects build without errors.

      I use Microsoft Visual C++ 6.0 Author Edition and i'm no C-guru ... can this be the problem? The Author Edition should work in normal way, but shows a popup-box when starting apps builded with it. I successfully build the MPEG4IP parts of OpenIPMP 0.81 with this one.


    • piano

      piano - 2006-09-15

      I installed service pack 5 for VS 6 as said in MPEG4IP FAQ, but its still the same, building went without errors and mp4player doesn't react to any parameters (or gives the memory-leak warning).

      @Danijel: can You give me the exact version/build number of Your VS? Maybee needless, because build gave no errors, but i'm running out of ideas ..


  • Essar

    Essar - 2009-10-12

    I too got the same problem. I was able to encrypt the mp4 content.
    But when i try to decrypt it only a  blank screen is seen.

    When I tried to play a non encrypted content it played the audio, but there is no video.In the case of protected file there is no Audio or video.

    I build on VC6 + XP SP2

    Could any one help me ?


  • avasilchenko

    avasilchenko - 2009-11-27

    I have some problems with roResponse. Can you share your roResponse. It will help me.

    Thanks in advance.

  • zhfufo

    zhfufo - 2010-01-24

    may be you should rebuild SDL.Dll and check  the message in drmplugin.log


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks