last steps of installing DRMPlugin

Help
Julsator
2008-06-12
2013-04-23
  • Julsator

    Julsator - 2008-06-12

    Hello together, I stuck while installing the DRMPlugin after successfully installing openipmp at the point with:

    Run ./cvs_bootstrap --disable-mp4live, make and make install" (needs root privileges).

    I got:
    -----
    Warning - faac uses libmp4v, but we've detected a version
    of mpeg4ip.  If you get errors building mp4live, please
    rebuild faac without mp4v2 support
    -----
    but I build it without mp4live - so maybe it`s not actually the point.
    The Error sounds like:
    -----
    configure.in:642: error: possibly undefined macro: AM_PATH_GLIB_2_0
          If this token and others are legitimate, please use m4_pattern_allow.
          See the Autoconf documentation.
    configure.in:644: error: possibly undefined macro: AM_PATH_GTK_2_0
    + exit 1
    -----
    does anyone solved this problem or knows how to rebuild faac without mp4v2 support?

    this is the complete trace:
    -----
    server:/opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5$ sudo ./cvs_bo
    otstrap --disable-mp4live
    Found SDL
    ./cvs_bootstrap: 78: Syntax error: Bad fd number
    server:/opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5$ sudo /bin/bas
    h ./cvs_bootstrap --disable-mp4live
    Found SDL
    Warning - faac uses libmp4v, but we've detected a version
    of mpeg4ip.  If you get errors building mp4live, please
    rebuild faac without mp4v2 support
    + mkdir -p ./config
    + for dir in /usr/local /usr/contrib /opt/gnome /usr /opt/local
    ++ which aclocal
    + test -d /usr/local/share/aclocal -a /usr/local/bin/aclocal '!=' /usr/local/bin/ac
    local
    + for dir in /usr/local /usr/contrib /opt/gnome /usr /opt/local
    ++ which aclocal
    + test -d /usr/contrib/share/aclocal -a /usr/local/bin/aclocal '!=' /usr/contrib/bi
    n/aclocal
    + for dir in /usr/local /usr/contrib /opt/gnome /usr /opt/local
    ++ which aclocal
    + test -d /opt/gnome/share/aclocal -a /usr/local/bin/aclocal '!=' /opt/gnome/bin/ac
    local
    + for dir in /usr/local /usr/contrib /opt/gnome /usr /opt/local
    ++ which aclocal
    + test -d /usr/share/aclocal -a /usr/local/bin/aclocal '!=' /usr/bin/aclocal
    + ACLOCAL_FLAGS='-I /usr/share/aclocal '
    + for dir in /usr/local /usr/contrib /opt/gnome /usr /opt/local
    ++ which aclocal
    + test -d /opt/local/share/aclocal -a /usr/local/bin/aclocal '!=' /opt/local/bin/ac
    local
    ++ pwd
    + pwd=/opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5
    + test Linux '!=' Darwin
    + for dir in '$pwd/lib/SDLAudio'
    + cd /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/lib/SDLAudio
    + aclocal -I /usr/share/aclocal
    + libtoolize --force
    + automake --add-missing --foreign
    + autoconf
    + cd /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/lib/rtp
    + aclocal -I /usr/share/aclocal
    + libtoolize --force
    + autoheader
    autoheader: WARNING: Using auxiliary files such as `acconfig.h', `config.h.bot'
    autoheader: WARNING: and `config.h.top', to define templates for `config.h.in'
    autoheader: WARNING: is deprecated and discouraged.
    autoheader:
    autoheader: WARNING: Using the third argument of `AC_DEFINE' and
    autoheader: WARNING: `AC_DEFINE_UNQUOTED' allows one to define a template without
    autoheader: WARNING: `acconfig.h':
    autoheader:
    autoheader: WARNING:   AC_DEFINE([NEED_FUNC_MAIN], 1,
    autoheader:             [Define if a function `main' is needed.])
    autoheader:
    autoheader: WARNING: More sophisticated templates can also be produced, see the
    autoheader: WARNING: documentation.
    + automake --add-missing --foreign
    + autoconf
    + cd /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5
    + cd /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/common/video/iso-mpeg4
    + aclocal -I /usr/share/aclocal
    + libtoolize --force
    + autoheader
    + automake --add-missing --foreign
    + autoconf
    + cd /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5
    ++ aclocal -I /usr/share/aclocal
    aclocal:configure.in:398: warning: macro `AM_PATH_ALSA' not found in library
    aclocal:configure.in:642: warning: macro `AM_PATH_GLIB_2_0' not found in library
    aclocal:configure.in:644: warning: macro `AM_PATH_GTK_2_0' not found in library
    + echo

    + grep AM_PATH_GTK_2_0 aclocal.m4
    + ACLOCAL_FLAGS='-I /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/doc -I
    /usr/share/aclocal '
    + aclocal -I /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/doc -I /usr/sh
    are/aclocal
    aclocal:configure.in:398: warning: macro `AM_PATH_ALSA' not found in library
    aclocal:configure.in:642: warning: macro `AM_PATH_GLIB_2_0' not found in library
    aclocal:configure.in:644: warning: macro `AM_PATH_GTK_2_0' not found in library
    + grep AM_PATH_ALSA aclocal.m4
    + ACLOCAL_FLAGS='-I /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/util -I
    /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/doc -I /usr/share/aclocal
    '
    + aclocal -I /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/util -I /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/doc -I /usr/share/aclocal
    aclocal:configure.in:642: warning: macro `AM_PATH_GLIB_2_0' not found in library
    aclocal:configure.in:644: warning: macro `AM_PATH_GTK_2_0' not found in library
    + libtoolize --force
    + autoheader
    + automake --add-missing --foreign
    + autoconf
    configure.in:642: error: possibly undefined macro: AM_PATH_GLIB_2_0
          If this token and others are legitimate, please use m4_pattern_allow.
          See the Autoconf documentation.
    configure.in:644: error: possibly undefined macro: AM_PATH_GTK_2_0
    + exit 1
    -----

    best regards

     
    • Julsator

      Julsator - 2008-06-12

      OK - to solve this problem and running into the next hint.
      ----
      sudo apt-get install build-essential libglademm-2.4-dev libglibmm-2.4-dev libgtkmm-2.4-dev
      ----
      to enshure that you`ve got some more used libs installed.

      Then running sudo bash ./cvs_bootstrap configure again -
      very much messages occure and it ended with:
      ----
      ...
      + grep AM_PATH_ALSA aclocal.m4
      + ACLOCAL_FLAGS='-I /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/util -I /usr/share/aclocal '
      + aclocal -I /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/util -I /usr/share/aclocal
      + libtoolize --force
      + autoheader
      + automake --add-missing --foreign
      + autoconf
      + echo 'Do not remove this file or you might have to re-bootstrap'
      + '[' '!' -x configure ']'
      + ./configure --enable-warns-as-err configure 'ACLOCAL_AMFLAGS=-I /opt/openipmp2/src/Demo/mpeg4ip/mpeg4ip-1.5/util -I /usr/share/aclocal '
      configure: WARNING: you should use --build, --host, --target
      checking for ./bootstrapped... yes
      checking build system type... Invalid configuration `configure': machine `configure' not recognized
      configure: error: /bin/bash ./config.sub configure failed
      + exit 1
      ----

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks