Issues with 1.7.2 on GNU/linux

Developers
2008-11-04
2013-05-02
  • Matevz Tadel

    Matevz Tadel - 2008-11-04

    Hi,

    First, thanks for the good work! I use DevIL for my off-work project since 2002 and it never failed me :)

    I have a couple of issues with 1.7.2 release:

    1. The tarball does not contain/start-with a DevIL/ directory.

    2. The files in the tarball have CRLF line endings. This means one has to fix the following files manually to configure / compile on GNU/linux:
      libtools/config.sub
      libtools/config.guess
      libtools/depcomp
      libtool
    Even after running 'libtoolize --force' the libtools/depcomp still needs to be un-dosed.

    3. There is no CVS tag for the release.

    4. I can't override CFLAGS meaningfully, -O3 is always injected among them. The CFLAGS appear three (3) times on the compile command line.

    Best,
    Matevz

     
    • Denton Woods

      Denton Woods - 2008-12-27

      Thanks, the new release (1.7.4) should fix 1 and 2.  I'm not really sure what you mean by 3.  I'll see if Matej has an idea on how to fix 4 if it still occurs in the new release.

       
      • Matevz Tadel

        Matevz Tadel - 2008-12-27

        Great, I'll try the new release today, thanks!

        With 3. I mean that you don't use cvs tag or rtag commands to mark the release in the repository - this makes it hard to retrieve the release via cvs checkout, like in 'cvs co -r v1-7-4'.

        Thanks also for looking into 4. - I'm not very good with autotools and DevIL's setup is quite complex.

         
        • Denton Woods

          Denton Woods - 2008-12-30

          I did not know that there was a command for tagging a release via CVS.  I just had to look it up and will be using it from now on.  Thanks a lot for pointing that out.

           
      • Matevz Tadel

        Matevz Tadel - 2008-12-27

        I've built 1.7.4 on two machines (fedora 7 (x86) and 10 (x86_64)) - everything works out of the box.

        I had to add '--enable-ILU --enable-ILUT' to my configure options as they are now disabled by default. 'configure --help' says:
          --with-ILU=yes/no       Build ILU part of DevIL. Default set to no
          --with-ILUT=yes/no      Build ILUT part of DevIL. Default set to no
        which does not work so it took me a while to figure it out.

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks