linker error under Visual Studio 2008

  • jaronimo

    jaronimo - 2009-10-30

    Hello everyone!

    I'm at a loss here.. I have been searching the forum und trying different approaches but nothing worked.

    for the past hours I have been trying to integrate DevIL into my OpenGL project. I did everythig that's in the manual and in the tutorials but I still get "LNK2001: unresolved external symbol __imp__ilInit@0 main.obj" everytime I compile.

    Under "Additional Include Directories" I put "\DevIL-SDK-x64-1.7.8\include" …no problem there.
    Under "Additional Library Directories" I put "DevIL-SDK-x64-1.7.8\lib"
    and under "Additional Dependecies" I put DevIL.lib

    Visual Studio seems to have no problem finding the .lib, since I get an error when I put for example blah.lib under "Additional Dependencies"

    so on the theoretical side of things my program should compile fine.. but nevertheless I get this damn linker error.

    I run Windows 7 32bit, Visual Studio 2008

    first I specified the paths to /include and /lib as global Visual Studio settings then I deleted the global settings and made them project specific.. but that did not change a thing.

    I really don't know what else I could be trying except maybe compile my own DevIL.lib… could this be the solution to the problem?

    Anyone got an idea what I could do to get rid of that linker error?

  • jaronimo

    jaronimo - 2009-10-30

    WTF.. after reading my post I just realized that I downloaded the 64bit version….. trying to find the 32bit version now.

  • jaronimo

    jaronimo - 2009-10-30

    oh god….. I'm so f'in stupid… now it works. I lost HOURS trying to figure out what was the problem… grrrr

    topic can be closed.


Log in to post a comment.