GT02A smartGps Device (china make mini gps)

Help
Anonymous
2011-08-19
2017-01-17
  • Anonymous - 2011-08-19

    Hi Martin, I am Newer to OpenGTS, Need your help. I have GT02A Gps Device. I tried connecting on different ports 31000, 31265, 31270, etc. (using various servers available with community edition).

    Logs made it clear that they are not able to understand the information sent by Device (binary/hex). Only taip decoded some of the communication. I need your help in integration of this device.

    I also tried with Android using gps2opengts. It's communicating well on gprmc servlet and I'm able to track this. I need help on converting the gps data and updating events data table.

    Also, I wonder that my device not providing any option to give an account id. Do I need to send a 'static' user to associate with devices ?

    Please help me…

     
  • Anonymous - 2012-03-11

    Hi Anthony,
    I have installed openGTS recently n its working fine.
    Only thing is i have to configure my GT02A device to communicate to it please help. I could not understand decoding the bit stream..
    Please help
    Which server(eg template, tk10x etc ) i have to use for this device ?
    also while running server on different port it show port conflict.. between all udp and tcp servers.
    Please help

     
  • Morris X Gump

    Morris X Gump - 2012-04-11

    Hi all,

    I just started a project to integrate the GT06 and reading the new protocol (I can provide it if you need it), I noticed that the unit must "login" to thet server with a special message, then he server must acknowledge that message, and after that the unit start to send location messages.

    The thing is that those location messages don't have the IMEI (or Unit ID) number on them, so I would like to know how did you bind that number, included in the login message, to the other location messages.

    I hope you can advise on that matter Anthony.

    Thanks for your time.

     
  • kmsb

    kmsb - 2012-04-28

    hi moxgump.. I too trying to get gt06 work with opengts. purchased few units and using conthinking.net tracking server. but I have my own opengts server running locally, and I want to be in control of location data of my clients devices.. to do backup and routing advice processing.

    what I've observed briefly is that gt06 sending some sort of binary string to server. no text. no gprmc sentence.
    so far talking to their sales no success at all.

    for start, can you share the protocol with me. hope we can work it out together.

    thanks

    shariff

     
  • Sandeep

    Sandeep - 2012-04-28

    i have a protocol developed for gt06 and its working.

    PM me for more details

    thank you

     
    • JH Ward, Software

      Hello Sandeep,

      Do you have a working DCS for any of these Concox devices?
      tr02, gt02, gt03a/b, gt06

      Thank you,
      John

       
  • kmsb

    kmsb - 2012-04-29

    gts enterprise has support for GT02 and GT06 from concox/cothinking. I will be nice opengts user can buy single DCS, I'm ok to spend few dollars for a dcs but not to buy the whole gps enterprise.

    matter of fact, I did contact every email available on geotelematics website for gts enterprise pricing, few times, no one responded. a bit strange feeling, could be some issues that I dont know.

     
  • Sandeep

    Sandeep - 2012-04-30

    Hey shariffkmsb,

    If OpenGTS solve your problem then why are you taking the GTS Enterprice.

    For every new device you required DCS Server which is compatible for that Device. So by default it is not available in OpenGTS.

    So best way is to hire a developer to develop the DCS Server

     
  • mirsunu

    mirsunu - 2012-05-29

    Dear shariffkmsb, so you have a protocol for gt06. So Guru, may I ask you to give me the protocol? It's really confusing me, I would like to know format sample from gt06 device which send to server.
    Thank you for your attention and cooperation

    Regards,

    Antonius

     
  • Ramesh Saruvamalai

    Send me your Protocol format of GT06. I will guide you to write the code. Its bit easy.

     
    • Manish Malik

      Manish Malik - 2016-05-12

      Hello Ramesh Ji,

      I am working on writing DCP for Coban device 306A. My server program is able to receive the login packet/data from deice on IP/Port provided by me but sending back the LOAD command don't seem to work. Attaching the protocol for the device. Please help me overcome this issue. Many Thanks.

       
  • i.vys

    i.vys - 2012-09-01

    Hi
    try my server tracker gt02a (information in Russian)
    http://www.ural.org/track/gt02a/opengts/

     
    • Lukman_vq vq

      Lukman_vq vq - 2014-10-27

      dear i.vys,

      i was following your step but i got the error when i build it see the error below

      [javac] method StringTools.parseString(byte[],int,String) is not applicable
      [javac] (actual and formal argument lists differ in length)
      [javac] method StringTools.parseString(byte[],String) is not applicable
      [javac] (actual argument String cannot be converted to byte[] by method invocation conversion)
      [javac] method StringTools.parseString(Object,String) is not applicable
      [javac] (actual argument char cannot be converted to String by method invocation conversion)
      [javac] /usr/local/OpenGTS_2.5.7/src/org/opengts/servers/gt02a/TrackServer.java:282: error: method createDatagramSocket in class ServerSocketThread cannot be applied to given types;
      [javac] sst = new ServerSocketThread(ServerSocketThread.createDatagramSocket(port));
      [javac] ^
      [javac] required: InetAddress,int
      [javac] found: int
      [javac] reason: actual and formal argument lists differ in length
      [javac] /usr/local/OpenGTS_2.5.7/src/org/opengts/servers/gt02a/TrackServer.java:323: warning: [rawtypes] found raw type: Class
      [javac] Class cmdPktClass = null;
      [javac] ^
      [javac] missing type arguments for generic class Class<T>
      [javac] where T is a type-variable:
      [javac] T extends Object declared in class Class
      [javac] /usr/local/OpenGTS_2.5.7/src/org/opengts/servers/gt02a/TrackServer.java:350: warning: [unchecked] unchecked conversion
      [javac] sst.setClientPacketHandlerClass(cmdPktClass);
      [javac] ^
      [javac] required: Class<? extends ClientPacketHandler>
      [javac] found: Class
      [javac] 5 errors
      [javac] 3 warnings

      BUILD FAILED
      /usr/local/OpenGTS_2.5.7/build.xml:2286: Compile failed; see the compiler error output for details.

       
    • johneric

      johneric - 2014-11-10

      Hi I've tried installing your DCS (@i.vys). I got some errors but I fixed it already. Now I got a warning "Ignoring commandport listener". Do I need to edit something? After that warning no more message from cmd, the cursor is just blinking on the cmd. Thanks for this.

       
      Last edit: johneric 2014-11-10
  • Quincy Hunte

    Quincy Hunte - 2012-10-06

    We have an older GPS platform that we are having some TCP port threading issues.

    When our GPS unit connects to our servers it connects with a TCP connection on a single port that the unit is programmed with, our application(service) then hands off to another port for continued communication on another thread.
    This action of spawning threads is a method used by "BOT" developers to enable them to tell your computer to attack other computers.

    When this occurs it appears that our servers are shutting down the connections to that port because there were too many and suspected that the service was acting like malware (BOT).
    We created the "watch dog" service to restart the other should it go down but this creates to many issues as it disconnects the units.

    Is there a way we should be threading or connecting multiple units to a port? 

     
  • johneric

    johneric - 2014-11-10

    Do I need to configure or set my GPS device like IP Address? or port? etc...

     
  • Henni

    Henni - 2015-10-29

    Hello,

    I am trying to get TR02, GT02, GT03A/B, GT06 devices to work with OpenGTS.

    Wonder if you got them to work yet? I will appreciate any help.

    Thx
    Henni

     
  • Maruti

    Maruti - 2017-01-17

    Hi
    Sir any one to need help me 0f GT02A dcs. i will payment you. email- marutikd91@gmail.com number-+918050357729

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks