Problem with reverse-geocoding.

  • Anonymous - 2011-07-14


    I'm trying to use the reverse-geocoding. I pick up an autorization key to use the reverse-geocoding provided by Google.

    I did the things showed in FAQ, but I dont get the address and when I tested It on CMD line, I got this error:

    Thank you.


  • Kushal Patel

    Kushal Patel - 2011-07-14

    give it a shot with a comma instead of a forward slash; 39.1,-142.1

  • Kushal Patel

    Kushal Patel - 2011-07-14

    ohh..  and it's not -gp… its -geoPoint=1.23/23.54

  • tea4two

    tea4two - 2011-07-14

    Reading screenshot it seems that are used wron parameters, like written by kushalx.

    The right command is:

    bin\rgTest.bat -pln=default -geoPoint=39.12345/-134.12345 -account=<place your account here>

    BTW  the account could be not required.

    I haven't tried it, but I refer to your screenshot.

    Let us know if you have success.

    - Pierluigi

  • Anonymous - 2011-07-14


    Kushalx, I tried like you said and I got the same error.

    Tea4two, What is the account you said? I tried some things but I got the same error again.

    Thank you

  • tea4two

    tea4two - 2011-07-15

    Hi Allan,
    to test reverse Geocoding the only requirement is to provide the coordinates.

    bin/rgTest.bat -geoPoint=44.27494/9.40395

    running previous command give to me:

    Ponte Serlupi, 16039 Sestri Levante Genoa, Italy

    BTW, i'm using Linux so the command to run is bin/, but it's the same for windows using bin/rgTest.bat.

    There is only one REQUIRED parameter to use with  rgTest:
    optional parameters are:
        -pln=<PrivateLabel Name/Host> if you virtual server, you can specify the one to test
       -account=<id> - to test the right behaviour of Reverse Geocoding of specific Account.
                                    You can enable or disable Reverse Geocoding for each account and choice if you need full or parzial RG.

    I hope now it's more clear.

    Before to run rgTest command you must compile OpenGTS, ant all, because  some libraries are required.

    Let us know if you have succes.

    - Pierluigi

  • Anonymous - 2011-07-16


    I tested like you said but I got the same result!

    But now I upgraded to the newest version (2.3.6) and my TK102 is working with the new template server and the reverse-geocoding is working too!

    Thank you for the help!


  • Martin Flynn

    Martin Flynn - 2011-07-16


    On Windows, command arguments must either be specified in quotes, or the options must be specified with a ":" separator, instead of "=" (ie. try "-gp:39.12345/-134.12345").  Please refer to one of the following sections in the OpenGTS_Config.pdf document for more information: "1.4-#5",  "4.1b", "7.b", or "B.2b".

    - Martin

  • Salvatore Castellano

    I noticed that this thread is getting old, but anyway, I ran into the same problems described above, and couldn't find any solution in the forums.
    I had to change the rgTest.bat file in order to fix this.
    Somewhere in the rgTest.bat the parameter "%1" was not added to the ARGS line; I changed this, and now it's working…

    set ARGS=-conf:"%GTS_CONF%" %1 %2 %3 %4 %5 %6

    Btw, use the directions of 'mdflynn' regarding the quotes or ":" separator…

    Best regards,

  • Flavio Ferreira

    Flavio Ferreira - 2013-05-16

    Bom dia Allan,

    Uso o Opengts e gostaria de saber qual dispositivo vc esta usando hoje, pois comecei a utilizar o Niagara2 da Magneti Marelli, mas devido um problema deles, talvez eles tenham dificuldade em fornecer este produto. Uso tambem os TK da Xexun, mas pretendo procurar outro fornecedor, como por exemplo, Contiental ou Maxtrack.
    Desde j[a agradeco

  • Anonymous - 2013-06-04

    Salvatore :  a virtual Beer for you!!


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks