Help save net neutrality! Learn more.
Close

GPRMC not logging data? No Error/debug logs?

johndknm
2012-12-29
2013-06-12
  • johndknm

    johndknm - 2012-12-29

    Hi.  Im exploring open GTS.  I have it installed and running and the sample database loaded and displayed successfully under the tomcat/apache turnkey linux VM.  Im using jdk 6.  Im testing.

    I have 2 issues.  Firstly GPRMC doesnt seem to be logging to the database events. 
    When I create a vehicle with the uniqueID gprmc_123456789012345  and  send this string to

    From the manual the test/default string which I think should just work is:
    http://192.168.1.28/gprmc/Data?id=123456789012345&code=0xF020&gprmc=$GPRMC,080701.00,A,3128.7540,N,14257.6714,W,000.0,000.0,180707,,,A*1C

    When sending this in the browser I get an OK response.  I cannot see any events appear for the vehicle ID though.

    Secondly - for the life of me I cannot get any logs to generate.  Ive edited the webapp.conf in the build root to uncomment everything that looks log related, recompiled and redeployed everything but nothing is produced.  I also tried update to 2.4.7 and repeat but no joy.

    Thanks for the help, would be a great app if I could get it to work. 

    Finally, any hosted turnkey installs so I can deploy the base system (track a few cars/phones only)

    Thanks
    John

    Im looking in $GTS_HOME/logs for log files and find / -name *.log doesnt reveal anything either

    WEBAPP.CONF

    # -- overrides
    # -- Logging
    # -- (output message logging specifications)
    # - log level (off, fatal, error, warn, info, debug, all)
    log.level=debug

    # - log name
    log.name=${%contextName=webapp}

    # - log dir/file
    log.dir=var/log
    log.file=${log.dir}/${log.name}.log
    log.file.enable=true

    # -- display log message (INFO level)
    #%log=(${log.name}:${%version}) Loading "${%configURL}"

    I tried setting logfiles to go to var/log
    no joy

    root@tomcat-apache /var/log# ls
    alternatives.log  auth.log  cron-apt    dmesg       dmesg.2.gz  fontconfig.log  lastlog   mail.info  messages   mysql.log       news           syslog       tomcat6
    apache2           boot      daemon.log  dmesg.0     dpkg.log    fsck            lpr.log   mail.log   mysql      mysql.log.1.gz  ntpstats       syslog.1     user.log
    apt               btmp      debug       dmesg.1.gz  faillog     kern.log        mail.err  mail.warn  mysql.err  mysql.log.2.gz  pycentral.log  syslog.2.gz  wtmp

                                      

     
  • johndknm

    johndknm - 2013-01-03

    Problem 1 solved
    I have got it logging with opengts free android app and using hardcoded string.
    it was a bit confusing in the docs about how to set the string right.  the device ID is irrelevant; its all about the account and device name

    using the demo account the following string generates an ok response; plus  when you look in database
    mysql -u root -p
    password

    use gts;
    select & from EventData;

    you can see it log records okay

    http://192.168.1.33/gprmc/Data?acct=demo&dev=gprmc&code=0xF020&gprmc=$GPRMC,080701.00,A,3138.7530,N,14257.6714,W,000.0,000.0,180707,,,A*44

    This put me in the pacific,  opengtsfree then logged me to my home :) (in australia)
    for opengts_free on android   set username to demo and create a vehicle under the demo account with test01 name

    still no idea how to get logging happening anyone??

     
  • johndknm

    johndknm - 2013-01-03

    for the hardcoded string I used acct demo and device  gprmc (which I created as a vehicle)

    for the opengtsfree i made error above.  I created the device test01 set the params in the app on the phone, got wifi and sat link, pointed it to the 192.168.1.33 server on the lan and then used the test button on the android app.  that sent a hardcoded string and got logged ok.

    then I let the phone do real data and voila

     
  • yiyo

    yiyo - 2013-03-21

    Hi, I have a problem with the wprmc, when I use the harcode:
    http://pru38as.no-ip.info:8080/gprmc/Data?acct=demo&dev=test01&gprmc=$GPRMC,184937,A,3128.7540,N,14257.6714,W,000.0,000.0,200313,,*3, the server returns me: GPSERROR
    From the webapp.config Ive uncomment:
    # -- GPRMC properties
    #gprmc.logName=gprmc
    #gprmc.defaultAccountID=gprmcx
    #gprmc.minimumSpeedKPH=5.0
    #gprmc.simulateGeozones=true
    gprmc.parm.account=acct
    gprmc.parm.device=dev
    #gprmc.parm.auth=pass
    #gprmc.parm.status=code
    #gprmc.parm.gprmc=gprmc
    gprmc.response.ok=GPSOK
    gprmc.response.error=GPSERROR
    If I comment GPSOK AND GPSERROR line and hardcode via web browser it doesnt return anything.
    The each time I trie to connect via HTTPS with gps2opengts via mi celphone the tomcat console shows:

    Mar 20, 2013 7:55:04 org.apache.tomcat.util.http.Parameters processParameters
    INFO: Invalid chunk starting at byte  and ending at byte  with a value of  ignored

    Do I have to start a DCS for these type of communication?
    Please help!

     

Log in to post a comment.