Problem in configure on RH 7.1

2001-08-11
2001-08-17
  • Amit Kumar Singh

    I have a pgsql ver 7.1. when i try to configure the openfts tcl packege as downloaded from the CVS IT GIVES ME AN ERROR   checking looking for postgresql include files... configure: error: couldn't find postgresql include files
    I tried giving all the possible variables for the pgsql install and include dir. It didn't help. Can some one tell me about the directive or the modification to be doen to configure the package. I have tried to install with the rpm version as well as compiled version of the pgsql.

     
    • Dan Wickstrom

      Dan Wickstrom - 2001-08-12

      Did you try ../configure --with-pgsql="PATH TO PG INSTALL DIRECTORY"?  If your already tried that, could you tell me where your postgres.h include file is located?

       
      • Amit Kumar Singh

        Thanks Dan,
        I was able to install the openfts (tcl version). I have tcl 8.3.2 aolserver 3.2-4 (ad version), opencas 3.2.5, pgsql 7.1.2. When I run the hello world tcl it gives me an error "permission denied" . What am i doing wrong. I did run the script as in the doc from user root.

        Regards

        amit

         
        • Dan Wickstrom

          Dan Wickstrom - 2001-08-14

          Ok, you lost me.  You say that you can now install the tcl version of openfts, but you're unable to the hello world tcl.  Are you talking about something from openacs or aolserver, or are you talking about something from openfts?  As far as I know there is no hello world script in openfts.

           
    • Amit Kumar Singh

      This is the part of documentation i was talking about in the doc priimer .html. Since i am new to programming and however i am able to install all the components there is no step by step documentation as to how can i index a postgres database. Even i dont know how to init an already created openacs database.
      If u can help that would be great.

      The package Search::OpenFTS::Parser is a wrapper around the parser functions. The particular functions that a parser must provide in order to work with
      OpenFTS are discussed in section VII (Customizations). Here's an example of how it can be used:

          #! /usr/local/bin/tclsh

          package require Search::FTS::Parser

          set txt "Hello World. OpenFTS rules!"

          Search::FTS::Parser::start_parser $txt

          foreach {type word} [Search::FTS::Parser::get_word] break

          while { $type } {

              puts "[Search::FTS::Parser::type_description $type] \t$word"

              foreach {type word} [Search::FTS::Parser::get_word] break

          }

          Search::FTS::Parser::end_parser

       
    • Amit Kumar Singh

      Ok the example given with openfts runs. I have been able to run and index the pages. I have done configure with aolserver. When i load nsfts.so in my nsd.tcl file the aolserver does not start and even there is no log enrty for the same. Can u help me on this

       
    • Amit Kumar Singh

      I was able to get the openfts running on the aolserver and integrated with openacs database. Can someone help me indexing the openacs site and querying of the same using the openacs model.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks