First day problems

  • lucio5295

    lucio5295 - 2005-08-23

    I have downloaded, but Im not been yet able to run any example file.
    Typing a file.flw after the statement Simulation data file the program is discharged and disappear.
    Where can I found a Help or a Tutorial with the necessary commands to manage this program?
    The chapter Getting Started on the the reference manual seems not useful to this pourpose.

    • Nobody/Anonymous

      I experienced the same issues.  You need download and install gmsh pre and post processor from  I have cygwin already on my PC.  Cygwin is a Linux-like environment for Windows.  gmsh launched a cygwin shell  so I'm not sure if cygwin is required to run gmsh or not. (

      Regardless, you use gmsh to generate a .msh file from the .geo file provided in the example.  Then you run openflower.

      I'm a windows troglodyte so I'm not sure about using command line structures.  I had to have the files I was using in the same directory as Openflower.exe

    • Nobody/Anonymous

      You can download the latest live Knoppix CD. Just google knoppix and look for the live CD. Turn off your computer put the CD in the cdrom and turn it back on... probably it would be more like turn it back on and quickly press the cdrom button so you can put your knopix cd in there. Anyway then you can have a pen drive to just plug it with GMSH and OPENFLOWER on it in binary form. you can also mount your regular winders disk and save stuff to it. with a 60$ 1gig pen drive you can run a little model and save your models and output. you would run from the desktop and then save the stuff back to the pen. Pen drives tend to be too slow to play stuff from them.

    • Nobody/Anonymous

      I also experience the same issues. 

      I have loaded an example in gmsh and I have created a msh file. 

      I have made a RunDir containing gmsh.exe, OpenFlower.exe, TD_cube_big_tet.flw, TD_cube_big_tet.geo and TD_cube_big_tet.msh.

      I run OpenFlower.exe in the RunDir.
      At the prompt, I type in "TD_cube_big_tet.flw".
      Then OpenFlower.exe closes.

      Does Flower require Cygwin?

      • Nobody/Anonymous

        I am running openflower without cygwin without problems. Try some of the different examples.. I occasionally crash openflower if I have a mesh it doesn't like.

    • Nobody/Anonymous

      You can also download caelinux It brings gmsh and openflower with it. I dont think the windows version of gmsh needs cygwin. You can simply download the binary at their webpage and it runs easily.

      Maybe you need to create a mesh first with gmsh. I am not sure.

    • Nobody/Anonymous

      The msh is also in the RunDir.

      caelinux sure looks nice!  I'm downloading now.

    • Nobody/Anonymous

      I have had the same problems ---

      If I run the openflower, it comes up in a dos shell, and when you try to enter the .flw file, it crashes and exits.
      If I open cygwin, and run from the cygwin shell, it works, you can open the openflower and gmsh programs from the cygwin shell.

      The solution may be to create a "working directory" with openflower, gmsh, and save the geo and msh files to it. Then you can run both openflower from the cygwin shell. Now that I have gotten over this I can proceed to the tutorial.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks