make

Help
Anonymous
2004-08-06
2013-04-09
  • Anonymous - 2004-08-06

    Hello

    I am trying to install OpenFlower on my debian machine. I follow the instructions in the Reference Manual.
    ./first_construction works fine.
    But when I make make I get two error messages: Error 1, Error 2. The error messages are here under.

    I really would like to understand what is going on. Writing a LES code is part of my project as PhD student and I thought I could as well join your project.

    Carcas.

    bugarach[olivier]/scratch/olivier/OpenFlower/openflower-v0.1.1> ./first_construction
    automake: configure.in: installing `./install-sh'
    automake: configure.in: installing `./mkinstalldirs'
    automake: configure.in: installing `./missing'
    creating cache ./config.cache
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking whether make sets ${MAKE}... yes
    checking for working aclocal... found
    checking for working autoconf... found
    checking for working automake... found
    checking for working autoheader... found
    checking for working makeinfo... found
    ./configure: C: command not found
    checking for ranlib... ranlib
    checking for gcc... gcc
    checking whether the C compiler (gcc  ) works... yes
    checking whether the C compiler (gcc  ) is a cross-compiler... no
    checking whether we are using GNU C... yes
    checking whether gcc accepts -g... yes
    checking for c++... c++
    checking whether the C++ compiler (c++  ) works... yes
    checking whether the C++ compiler (c++  ) is a cross-compiler... no
    checking whether we are using GNU C++... yes
    checking whether c++ accepts -g... yes
    checking for a BSD compatible install... /usr/bin/install -c
    updating cache ./config.cache
    creating ./config.status
    creating ./Makefile
    creating ./src/Makefile
    creating ./src/Boundaries/Makefile
    creating ./src/Equations/Makefile
    creating ./src/Geometry/Makefile
    creating ./src/Kernel/Makefile
    creating ./src/Maths/Makefile
    creating ./src/Post_proc/Makefile
    creating ./src/Utils/Makefile
    creating config.h
    bugarach[olivier]/scratch/olivier/OpenFlower/openflower-v0.1.1> make
    make  all-recursive
    make[1]: Entering directory `/scratch/olivier/OpenFlower/openflower-v0.1.1'
    Making all in src
    make[2]: Entering directory `/scratch/olivier/OpenFlower/openflower-v0.1.1/src'
    Making all in Boundaries
    make[3]: Entering directory `/scratch/olivier/OpenFlower/openflower-v0.1.1/src/Boundaries'
    c++ -DHAVE_CONFIG_H -I. -I. -I../..  -I../Utils -I../Geometry    -g -O2 -c boundary_condition.cpp
    In file included from boundary_condition.cpp:7:
    boundary_condition.h:29: `ifstream' was not declared in this scope
    boundary_condition.h:29: `data_file' was not declared in this scope
    boundary_condition.h:29: variable or field `Read' declared void
    boundary_condition.cpp:23: no `void BoundaryCondition::Read(ifstream &)' member function declared in class `BoundaryCondition'
    make[3]: *** [boundary_condition.o] Error 1
    make[3]: Leaving directory `/scratch/olivier/OpenFlower/openflower-v0.1.1/src/Boundaries'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/scratch/olivier/OpenFlower/openflower-v0.1.1/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/scratch/olivier/OpenFlower/openflower-v0.1.1'
    make: *** [all-recursive-am] Error 2
    bugarach[olivier]/scratch/olivier/OpenFlower/openflower-v0.1.1>

     
    • Alexandre Chatelain

      Hello,

      It's seems that the problem U arose is just a compilation problem due to your compiler version : we develop under Mandrake and it seems that the error U have was not detected by our compilers (even though the code worked just fine).

      Anyway we are working on this part of the code presently and it seems that it was corrected.

      A new release will be posted in a couple of days... I hope !

      See U soon,

      VF

       
    • Anonymous - 2004-08-09

      Thanks for the answer.

      Carcas

       
    • Anonymous - 2004-08-09

      Hello

      I was thinking that the version of gcc might be the reason why it doen't work.

      Which version do you have ?

      Cheers

      carcas

       
    • Alexandre Chatelain

      Hi,

      the version of gcc we use is the following :
      gcc version 2.95.3

      VF

       
    • Tushar

      Tushar - 2004-11-18

      Hello,

      I downloaded the openflower v 0.3 from the web. While compiling the code, I got the same errors as user carcas was getting.

      I am compiling the code on a SGI machine with RedHat Linux. I was also looking for the updated code but could not find that. It will be very helpful, if you can point me a way out.

      Thanks
      -TG

       
    • Alexandre Chatelain

      Hi,
      You can try to put the include file between " " instead of < >.

      Some compilers (for example under windows) do not accept inclusion of files (such as ifstream, iostream...) with the following syntax: <iostream.h>

      You can try this then...

      Hope it helps...
      VortexFlow.

       
    • Tushar

      Tushar - 2004-11-19

      Thanks VortexFlow,

      I could compile the code. However I had to make following modifications:
      Add #include <iostream>
      #include <fstream>
      in AlgoAllenCahn.h
      in Equation.h
      in Octree.h

      Add #include "Variables.h"
      in PostProcField.h

      Tushar

       
    • matt

      matt - 2005-06-26

      Hello all,

      I am very interested in trying out OpenFlower.
      I have downloaded the OpenFlower packages asn LASpack and extracted them into a folder within my home directory. I then tried to make them.

      I am using Mandriva 2005.

      When making the OpenFlower v1.0 package, it seems to progress OK for a while then it gets errors in mesh.cpp saying that sqrt and pow functions ure undeclared.

      I am wondering if anyone has any ideas as to what I might be doing wrong. I didn't want to start hacking with the source files yet because I thought I might be doing something wrong. Would it help if I put #include "math.h" or something along those lines in the mesh.cpp file?

      Any suggestions would be much appreciated.

      Thanks in advance,
      Matt

       
    • Alexandre Chatelain

      Hi Matt,

      Well there is indeed a small thing to fix in the mesh.cpp file: in fact you are right and you have to add the <math.h> include file.
      The fact is that some compilers know how to get some include files and override this error.

      I already had this problem when porting OpenFlower to Windows and corrected it: it will be corrected in the next version v1.0.1 which will include output post-processing format for Tecplot.

      See U soon,
      VortexFlow.

       
    • matt

      matt - 2005-06-27

      Hi VortexFlow,

      Thanks for your assistance.
      I look forward to seeing v1.01!

      Thanks,
      Matt

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks