installation openemr not found error

Help
Doktoro
2012-08-23
2013-04-06
  • Doktoro

    Doktoro - 2012-08-23

    I installed OpenEMR 4.1 on Ubuntu 12.04.

    Using "http://localhost/openemr returns with an "ERROR Not found" message

    The server itself seems to be working. http://localhost/ gives me "It Works!"

    I noticed no unusual error messages during installation. It asked me for the mysql password, which I gave it.

    Suggestions?

    Thanks!

     
  • Doktoro

    Doktoro - 2012-08-28

    Hi Brady,

    I used the Ubuntu package. I tried to install the patch, but when I got to the part where you run the sql_patch.php script through the browser, I got the same error message. The php file is there, and it is in the correct directory, and the zip file extracted all of the new files into their directories correctly, so everything seems to be in the right place.

    Just for giggles, I turned off any blocking software in my browser and tried it - same result. Then I fired up my backup browser, Chromium, for which I have no protection installed and tried it - same result.

    Would there be a problem with permissions in the openemr directory? I'm not running the browser as root, I'm running it as a normal user.

     
  • Brady Miller

    Brady Miller - 2012-08-29

    Hi,

    Copy/paste the content of these two files here:
    /etc/openemr/openemr.conf (if there happens to be a password or two in here, then remember to mask them out)
    /var/log/openemr/install

    -brady
    OpenEMR

     
  • Doktoro

    Doktoro - 2012-09-04

    contents of /etc/openemr/openemr.conf

    #Optional settings
    #(currently empty, plan to use in subsequent versions of OpenEMR)

    #Installation settings
    # (DO NOT EDIT below!!!)
    process=pending
    plan=install

    contents of /var/log/openemr/install

    Thu Aug 23 13:00:33 EDT 2012: Configuring package…
    Thu Aug 23 13:00:33 EDT 2012: Installing OpenEMR
    Thu Aug 23 13:01:18 EDT 2012: Passed the mysql check loop
    Thu Aug 23 13:01:19 EDT 2012: Installing/Configuring OpenEMR…
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Warning:  substr() expects parameter 1 to be string, array given in /var/www/openemr/library/classes/Installer.class.php on line 298
    PHP Deprecated:  Assigning the return value of new by reference is deprecated in /var/www/openemr/gacl/adodb/adodb-xmlschema.inc.php on line 367
    PHP Deprecated:  Assigning the return value of new by reference is deprecated in /var/www/openemr/gacl/adodb/adodb-xmlschema.inc.php on line 379
    PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in /var/www/openemr/gacl/adodb/adodb-xmlschema.inc.php on line 1305
    <b>Configuration:</b><br/>
    driver = <b>mysql</b>,<br/>
    host = <b>localhost</b>,<br/>
    user = <b>openemr</b>,<br/>
    database = <b>openemr</b>,<br/>
    table prefix = <b>gacl_</b>Testing database connection…<br/>
    <font color="green"><b>Success!</b></font> Connected to &quot;<b>mysql</b>&quot; database on &quot;<b>localhost</b>&quot;.<br/>
    Testing database type…<br/>
    <font color="green"><b>Success!</b></font> Compatible database type "<b>mysql</b>" detected!<br/>
    Making sure database "<b>openemr</b>" exists…<br/>
    <font color="green"><b>Success!</b></font> Good, database "<b>openemr</b>" already exists!<br/>
    <font color="green"><b>Success!</b></font>
    First Step of Access Control Installation Successful!!!<br><br/>
    <html>
    <head>
    <title>OpenEMR ACL Setup</title>
    <link rel=STYLESHEET href="interface/themes/style_blue.css">
    </head>
    <body>
    <b>OpenEMR ACL Setup</b>
    <br>
    All done configuring and installing access controls (php-GACL)!
    </body>
    </html>

    Thu Aug 23 13:01:51 EDT 2012: Done configuring OpenEMR
    Thu Aug 23 13:01:51 EDT 2012: Configuring Apache for OpenEMR
    Thu Aug 23 13:02:37 EDT 2012: Added entries to apache configuration to secure directories with patient information.
    Thu Aug 23 13:02:37 EDT 2012: Placed backup of your original apache configuration file to /etc/apache2/httpd.conf.BAK
    Thu Aug 23 13:02:37 EDT 2012: Done configuring Apache
    Thu Aug 23 13:02:37 EDT 2012: Configuring PHP for OpenEMR
    Thu Aug 23 13:02:37 EDT 2012: We changed the following setting(s) in your php configuration file at /etc/php5/apache2/php.ini :
    Thu Aug 23 13:02:43 EDT 2012: (We have placed a backup of your php configuration at /etc/php5/apache2/php.ini.BAK)
    Thu Aug 23 13:02:43 EDT 2012: Successfully set max_execution_time = 60
    Thu Aug 23 13:02:43 EDT 2012: Successfully set max_input_time = 90
    Thu Aug 23 13:02:43 EDT 2012: Successfully set post_max_size = 30M
    Thu Aug 23 13:02:43 EDT 2012: Successfully set magic_quotes_gpc = On
    Thu Aug 23 13:02:43 EDT 2012: Successfully set upload_max_filesize = 30M
    Thu Aug 23 13:02:43 EDT 2012: Done configuring PHP
    Thu Aug 23 13:02:43 EDT 2012: Restarting Apache service
    * Restarting web server apache2
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.
       …fail!
    invoke-rc.d: initscript apache2, action "restart" failed.
    Thu Aug 23 13:06:00 EDT 2012: Unable to upgrade from 4.1.0-1 version package with package method, so can not upgrade the OpenEMR Package.
    Thu Aug 23 13:06:00 EDT 2012: EXITING……….
    Tue Sep  4 10:40:53 EDT 2012: Unable to upgrade from 4.1.0-1 version package with package method, so can not upgrade the OpenEMR Package.
    Tue Sep  4 10:40:53 EDT 2012: EXITING……….
    Tue Sep  4 10:42:24 EDT 2012: Unable to upgrade from 4.1.0-1 version package with package method, so can not upgrade the OpenEMR Package.
    Tue Sep  4 10:42:24 EDT 2012: EXITING……….

    looks like there was a problem, and my subsequent attempts to reinstall didn't go as hoped.

     
  • Brady Miller

    Brady Miller - 2012-09-04

    Hi,

    You actually have OpenEMR installed (all that is left to do in the package install was to restart apache, modify config to show process complete  and give a success screen). The thing that is broken is Apache (likely not related to OpenEMR); it appears that you may have a non-official Apache installed, so when try to start the official Apache service it does not work (just guessing…).

    What are you seeing in the Apache error log at /var/log/apache2/error.log ?

    Try command:
    sudo service apache2 restart

    Again, is it working and if not, are you seeing anything in the apache error log?

    -brady
    OpenEMR

     

Log in to post a comment.