how to reinstall openemr 4.1.1-1 on a ubuntu 12.10 machine?

  • izquierdista

    izquierdista - 2013-08-17

    Hi a few days ago i successfully installed openemr locally on my laptop and was using it without a problem. I accidentally erased the "layout based forms" list and so decided to do a fresh install of openemr.

    I tried uninstalling by accessing the .deb package with gdebi package instaler but it was aborted. I then tried clicking on "reinstall" and i get the following error "this package can not upgrade OpenEMR" because OpenEMR is not installed at /var/www/openemr"

    What do i need to do to be able to do a fresh install???

  • Brady Miller

    Brady Miller - 2013-08-17


    Try this on the commandline:
    sudo dpkg -r openemr

    (note this will remove OpenEMR and all of it's data)


  • izquierdista

    izquierdista - 2013-08-17

    Hi Brady,
    this is what I get when I tried the commandline:

    chacmool@chacmool-HP-Mini-110-3100:~$ sudo dpkg -r openemr
    [sudo] password for chacmool:
    (Reading database ... 245240 files and directories currently installed.)
    Removing openemr ...
    grep: /etc/openemr/openemr.conf: No such file or directory
    grep: /etc/openemr/openemr.conf: No such file or directory
    find: `/var/www/openemr/sites/*': No such file or directory
    sed: can't read /etc/apache2/httpd.conf: No such file or directory
    dpkg: error processing openemr (--remove):
    subprocess installed pre-removal script returned error exit status 2
    postinst asked to do abort-remove
    Errors were encountered while processing:

    8/17/13 6:56PM EDIT

    I tried installing the newest release using the 4.1.2-1_all.deb
    package and was also unable to do so because it says that the upgrade is unable to be performed.

    Last edit: izquierdista 2013-08-18
  • Jack Chan

    Jack Chan - 2013-08-23

    I had this problem before. Hope this will help.
    At the commandline type mysql -u root -p
    Give the root Mysql password
    drop database openemr;

    Then start a fresh installation with openemr-4.1.1.tar.gz instead of *.deb.

    I still cannot install version 4.1.2 ( I am using Fedora 19) despite both upgrade and fresh installation! Help needed.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks