Psychiatry Set

  • Mangalesh

    Mangalesh - 2013-02-27


    I am trying to set up psychiatry forms using Psychiatry Set but getting the following error. (The same error also comes for some other forms too…will list and post in the same thread).:

    ERROR: could not open table.sql, broken form?

    Kindly help.
    MJ :)

  • Brady Miller

    Brady Miller - 2013-02-28

    Hi MJ,

    The contrib directory is in need of a serious clean up. There was a discussion in the weekly conference call several weeks ago to begin removing broken forms etc. and I think the psychiatry set should be on that list; from my memory those forms had some incomplete functionality also (regarding the autosaving).

    I think Art and Tony were planning to remove some of the outdated/broken forms. If so, lets add the psychiatrySet to the list.

    Please post the other forms where you are seeing this error and also let us know your OpenEMR version.


  • Rod Roark

    Rod Roark - 2013-02-28

    I'd hate to throw away knowledge or code that may be useful some day.  Let's make a point of making them easy to get, and telling people how to do that.


  • Sherwin Gaddis

    Sherwin Gaddis - 2013-02-28

    I agree with Rod on this one to keep the forms because someone may take them up and update them.


    How did you get the error message you received?
    You might want to check the table.sql file to update ENGINE=MyISAM to  ENGINE=InnoDB.

    Also remove them from the psychiatrySet folder and place the individual folders in the forms directory.
    They should run correctly after doing these things.

    Let me know if you have any more questions.


  • Nathan

    Nathan - 2013-02-28


    Sherwin is correct,Place all forms in individual folders,then  try to access it by one by one,

    Hope it helps

    Please let me know,If need any code fix


  • Mangalesh

    Mangalesh - 2013-02-28

    Hi Guys,

    Thanks for the prompt replies. I actually copied Psychiatry Set folder from contrib/forms to interface/forms. Then I registered the same from Administration/Forms option. And then when I click of Install DB, I get the given error under Forms Administration. So what is the reason and the solution? BTW I am using v4.1.1(10)

    Thanks in advance.
    MJ :)

  • Mangalesh

    Mangalesh - 2013-02-28

    Hey I got it friends. As Sherwin suggested, after copying subfolders to the forms, it worked. Thanks a lot Sherwin and all.
    MJ :)

  • Nathan

    Nathan - 2013-02-28


    Here is my responses

    You need to copy & paste the below three folder from openemr/contrib/psychiatrySet into openemr/interface/forms




    FYI : These forms are not using the security model

    Hope this helps


  • Mangalesh

    Mangalesh - 2013-02-28

    Thanks Srini, I got it.
    MJ :)

  • Pieter W

    Pieter W - 2013-02-28

    This seems to be an orriginal Dutch (Leemhuis?) contribution. If there is a wish for translation please let me know and I will give it a try…..

    Or we could make a reverse translation Google document ???????????

  • David

    David - 2013-03-01

    If there is a way to import and export layout based forms we will contribute our set of psych forms in LBF.
    They were developed for use with a smartphone or tablet but they work great on the big screen too.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks