OpenCyc doesn't initialize

2007-08-08
2013-05-28
  • Cameron Ross

    Cameron Ross - 2007-08-08

    I get the following error when I run run-cyc.bat:

    Cyc 10 (Windows 32-bit)
    Copyright (C) 1995 - 2006 Cycorp, Inc.  All rights reserved.
    RTL (Win32 Threads) initialized.
    Error: String "18287931-d871-11d9-8eef-0002b3891c5a" is not a valid GUID.
    [Switching to single-threaded mode ....]

    Select a restart:
      0: Recursive read loop.
      1: Exit program.
    ?

    I'm running OpenCyc version 1.0 on Vista.

    Thanks much,
    Cameron Ross.

     
    • Giannis

      Giannis - 2007-08-09

      I think that thats a security problem... I have similar problems on Windows XP and the ResearchCyc API and I suspect that the company has failed to update the software to meet the recent updates from Microsoft. Actually I am unable to access the API on port 3601 at all. I think if you really want to do some serious work with Cyc technology you have to install it on a Linux machine.

       
    • Mei

      Mei - 2008-07-15

      I can run ResearchCyc on Windows XP and ResearchCyc API, but I couldn't run it on Vista. I got the same error message as Cameron.

       
    • David Whitten

      David Whitten - 2009-09-04

      Has anyone tried the new OpenCyc 2.0 for compatibility to MS Windows Vista OS ?

       
    • TerryCox

      TerryCox - 2009-09-06

      OpenCyc 2.0 works perfectly with Vista. The only issue I had was regarding a "No 'server' JVM' message on my 32-bit implementation, using the 1.6.0_12, easily fixed by copying a folder. An installation on a 32-bit Vista machine didn't even have that problem.

       
  • Steven Conklin

    Steven Conklin - 2009-09-17

    Finally got OpenCys 2.0 to run in Vista by reading the note about No server JVM message above. I created a server folder in Program Files/Java/jre6/bin and placed a copy of jvm.dll into it.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks