Again, please make sure to keep the mailing list in the thread. This is information other people might google. 

Please read: "Build and Install the Subscriber Registry and Sipauthserve" not OpenBTS. That's the configuration you're missing. 

On Sun, Nov 4, 2012 at 11:30 PM, Sundus Tahir <> wrote:
I think the error may be in the part where configuration options were supposed to be modified. This is what it says on the webpage:


OpenBTS.db is the database store for all OpenBTS configuration. It must be installed at /etc/OpenBTS, which likely does not exist. So, to create this file:

(from the OpenBTS directory)
sudo mkdir /etc/OpenBTS
sudo sqlite3 -init ./apps/OpenBTS.example.sql /etc/OpenBTS/OpenBTS.db ".quit"

This generates a lot of stock configuration options. You can find these listed here. Most of these only need to be tweaked if you are moving beyond a simple desktop setup. However, a few are required for basic operation. These are:

  • GSM.Radio.Band - Set this to the GSM band appropriate for your hardware.
  • GSM.Radio.C0 - This is the  ARFCN. Set it to something appropriate for your band.
  • Control.LUR.OpenRegistration - Set this to a  regular expression matching the IMSIs of your test phones. This tells OpenBTS to not reject your handset just because your registration server (below) isn't responding. Useful for debugging and initializing the system.

The values can be modified from OpenBTSCLI with the config command. For example,

config GSM.Radio.Band 900
config GSM.Radio.C0 1
config Control.LUR.OpenRegistration *

I'm not sure how to do this. Do I go into openbtscli.cpp and put these commands in?
Your help will be appreciated.

On Mon, Nov 5, 2012 at 12:12 PM, Sundus Tahir <> wrote:
I think I've followed all the instructions correctly, and yet when I run ./sipauthserve I get this error:

/public/subscriberRegistry/trunk$ ls
configFiles  sipauthserve      SubscriberRegistry.cpp
COPYING      servershare.cpp          sipauthserve.cpp  SubscriberRegistry.h
hexmapper    servershare.h            srmanager.cgi     syslogextractor
Makefile            srmanager.cpp
sundus@sundus:~/public/subscriberRegistry/trunk$ sudo ./sipauthserve
terminate called after throwing an instance of 'ConfigurationTableKeyNotFound'

Running this command in public/subscriberRegistry gives a "command not found" error, so I ran it in subcriberRegistry/trunk instead.

what do you think could be the problem?

On Mon, Nov 5, 2012 at 4:41 AM, Kurtis Heimerl <> wrote:
SVN root is the root directory of the SVN repository. sipauthserve is located at root/SubscriberRegistry/trunk

On Sun, Nov 4, 2012 at 8:03 AM, Sundus Tahir <> wrote:
Where exactly do we build and configure sipauthserve for running openBTS?
On this webpage:
it says, build it from svn root.
svn is not a directory, it's just a file.
LogMeIn Central: Instant, anywhere, Remote PC access and management.
Stay in control, update software, and manage PCs from one command center
Diagnose problems and improve visibility into emerging IT issues
Automate, monitor and manage. Do more in less time with Central
Openbts-discuss mailing list