this may not be the best place to ask this, but i know no other.
The fact is that i was using BeOS personal edition 5.03 with openBFS 4 (home-compiled, no debugging turned off) and some parts of openBeOS (openBFS, OpenTracker) everything had worked well (great work!) until this morning, i booted into BeOS (with lilo) as usual and left the computer on, a couple of hours later, i came back and BeOS was showing me the debugging terminal that said something about Registrar and the stack (i didn't pay much attention, though) "exit" i typed, but it did nothing, so i just hard-rebooted the machine (i used the button, i mean) but when i tried to boot again, the Be boot loader complained there was no bootable BeOS partition.
Any ideas of how can i repair this?

PD: Linux Mandrake 9.0 and BeOS installed, both in their respective hard disks (No windows installed).
PD2: I've been using this same version of openBFS for quite a long time now, so it may not be the problem. I was using the Registrar that came together with the standard version of BeOS.