#83 Missing dependencies (-lz -lreadline)

1.4.1
closed-works-for-me
5
2011-07-12
2011-01-19
Marc Boyer
No

It seems that some dependecies are not checked by the .configure.
I have an Ubuntu 10.04

I had trubles with
-lz (in src/lisp) => installation of zlig1g-dev
-lreadline (in src/lisp) => installation of readline-dev

Regards,
Marc Boyer

Discussion

  • Gabriel Dos Reis

    hi Marc,
    Thanks for the report. I need a few things:
    -- which version of OpenAxiom are you trying to build?
    -- what Lisp system and what version of that Lisp are you using to build OpenAxiom?

    -- Gaby

     
  • Marc Boyer

    Marc Boyer - 2011-01-24

    The Open Axiom version is 1.3.0
    The Lisp System is gcl (Ubuntu paquage 2.6.7-56)
    GCL (GNU Common Lisp) 2.6.7 CLtL1 Feb 15 2010 17:54:25

     
  • Gabriel Dos Reis

    • milestone: --> 1.4.1
    • status: open --> closed-works-for-me
     
  • Gabriel Dos Reis

    Hi Marc,

    I am unable to reproduce these problems.
    In genera, I OpenAxiom cannot install those dependencies
    for you -- just like it would not install the C or C++ dependency
    for your. I would suggest to install those that you have spotted.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks