#39 patch for MacOSX compile

3.2.0
closed
Bug fix (24)
5
2012-08-14
2007-10-04
No

The current svn revision of interpreter-3.x/trunk does not compile on MacOSX, because INT64_MAX cannot be found due to some dodgy preprocessor error. To enable the compilation of the soon to be released 3.2.0 on mentioned platform, this patch, or an equivalent one needs to be applied. This patch is not in the capability based vein, but does work. It needs to be applied to kernel/platform/unix/PlatformDefinitions.h.

Discussion

  • Rene Vincent Jansen

    patch for kernel/platform/unix/PlatformDefinitions.h

     
  • Rick McGuire

    Rick McGuire - 2007-10-05

    Logged In: YES
    user_id=1125291
    Originator: NO

    Rene, before I commit this, could you check if the conditional

    ifndef INT64_MAX

    rather than

    ifdef APPLE

    will fix the problem on the Mac? I'd prefer using that instead.

     
  • Rick McGuire

    Rick McGuire - 2007-10-14

    Logged In: YES
    user_id=1125291
    Originator: NO

    Committed revision 964.

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks