#105 Missing links on x86_64

v4.1.0
closed
Bug fix (24)
5
2012-08-14
2010-11-03
Anonymous
No

Some of the libraries were not linked properly, causing the automated tests fail. The environment used was OpenSUSE 11.3 x86_64.

Adding these directives to platform/unix/oorexx.spec.in solved the problem:

ln -sf %{_libdir}/ooRexx/librexxutil.la %{_libdir}/librexxutil.la
ln -sf %{_libdir}/ooRexx/librexxutil.so %{_libdir}/librexxutil.so
ln -sf %{_libdir}/ooRexx/librexxutil.so %{_libdir}/librexxutil.so.@ORX_SUBST_CURRENT@
ln -sf %{_libdir}/ooRexx/librexxutil.so %{_libdir}/librexxutil.so.%{orx_libversion}

ln -sf %{_libdir}/ooRexx/librxmath.la %{_libdir}/librxmath.la
ln -sf %{_libdir}/ooRexx/librxmath.so %{_libdir}/librxmath.so
ln -sf %{_libdir}/ooRexx/librxmath.so %{_libdir}/librxmath.so.@ORX_SUBST_CURRENT@
ln -sf %{_libdir}/ooRexx/librxmath.so %{_libdir}/librxmath.so.%{orx_libversion}

ln -sf %{_libdir}/ooRexx/librxregexp.la %{_libdir}/librxregexp.la
ln -sf %{_libdir}/ooRexx/librxregexp.so %{_libdir}/librxregexp.so
ln -sf %{_libdir}/ooRexx/librxregexp.so %{_libdir}/librxregexp.so.@ORX_SUBST_CURRENT@
ln -sf %{_libdir}/ooRexx/librxregexp.so %{_libdir}/librxregexp.so.%{orx_libversion}

ln -sf %{_libdir}/ooRexx/librxsock.la %{_libdir}/librxsock.la
ln -sf %{_libdir}/ooRexx/librxsock.so %{_libdir}/librxsock.so
ln -sf %{_libdir}/ooRexx/librxsock.so %{_libdir}/librxsock.so.@ORX_SUBST_CURRENT@
ln -sf %{_libdir}/ooRexx/librxsock.so %{_libdir}/librxsock.so.%{orx_libversion}

Discussion

  • David Ashley

    David Ashley - 2010-11-03

    This patch did not include all the libraries so I added all the libraries for the future.

     
  • Mark Miesfeld

    Mark Miesfeld - 2010-12-05

    Included in the 4.1.0 release

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks